Text editors

Atto inserts class="img-responsive" into images

 
This discussion has been locked because a year has elapsed since the last post. Please start a new discussion topic.
John Provasnik at Moodle Moot US
Atto inserts class="img-responsive" into images
Group Particularly helpful Moodlers

Whenever I add an image with Atto and adjust the width to a specific size I want, I save and then the image gets a class="img-responsive" inserted as well. Anyway to prevent this? I don't want the image to be responsive, which is why I'm trying to specific a specific size. 

Edit: Moodle 3.0.4

 
Average of ratings: -
Picture of Dave Balch
Re: Atto inserts class="img-responsive" into images
Group Core developersGroup Particularly helpful MoodlersGroup Plugin developers

Do you have "Auto size" checked in the image properties dialog?

Try un-checking it (it may add itself back if you open and save the image properties again).

 
Average of ratings: Useful (1)
John Provasnik at Moodle Moot US
[Solved] Re: Atto inserts class="img-responsive" into images
Group Particularly helpful Moodlers

Yes Dave! That solved my problem!

That is a little sneaky of Atto wink

So I was checking the "Auto Size" box to proportionally change the image length when I changed the width. The trick is (as you pointed out) to then 'uncheck' that box right before I save.

Yes, you are correct -- when you go back to edit the image again, the box will again be checked, so one needs to un-check it before saving. This would be nice to add into the docs somewhere.

Thanks for helping me with this!

 
Average of ratings: -