Text editors

Atto misbehaving

 
math
Atto misbehaving
 

Greetings!

Moodle 2.9.4+ (Build: 20160218) (very recent update - just a few days ago, from 2.9.1+)

I only noticed this today, so I can't pin it directly to the above referenced update or recent Atto additions.

Atto is misbehaving, but not in all modules. The behavior is:

  • Applying formating to text that is not selected.
  • Inserting hyperlinks as the actual URL - linked - rather than linking the selected word or image

Example:

If I enter the following text in the Page content box of  Page module and select the text to bullet (One Two Three):


It becomes this:


It seems to always apply the bullet to the last item on the page, even if it is an image.

Trying to make the word "Google" into a hyperlink yields this:


The link appears as text of the URL, linked. Somethimes it inserts it in the middle of the text selected, like "Goohttp://www.google.comgle.

I have begun uninstalling recent Atto add-ons:

Wordimport - uninstalled through Moodle admin, then deleted directory from server. Purged caches.

Did not solve problem.

Have recently also installed Chemistry, Matrix, and Computer Science add-ons -and a few others weeks and months ago.

I will start uninstalling the add-ons, but wanted to go ahead and get this posted, in hopes of time-saving advice from the community!

I am doing all of this uninstalling and testing on our test server, but the problem is occuring on our production servers (2). I did install the add-ons mentioned on the test server and tried them out for a few days first with no problems. They were all installed before the upgrade to 2.9.4.

Debugging is turned up all the way, but not errors reported.

And the behavior is not consistent across all instances of Atto. The problem doesn't occur in the body of a test question, but it does in the answer choice and feedback boxes. It occurs in Page, as described above, but not in Book.

I have restored the Atto tool bar settings to their default, but have only uninstalled Wordimport.

Our server guy did have to enable the XSL extension on the test and student production server, but the problem occurs in our Professinal Development instance where XSL was already enabled.

Any help would be greatly appreciated!

Thanks,

David

 
Average of ratings: -
Picture of Helen Foster
Re: Atto misbehaving
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTestersTranslators
Hi David,

Sorry to hear of your problems with Atto. If you've not done so already, how about checking in the Moodle Tracker whether others have reported similar problems. Hopefully this link will work: https://tracker.moodle.org/issues/?jql=project%20%3D%20MDL%20AND%20component%20%3D%20%22HTML%20Editor%20(Atto)%22%20ORDER%20BY%20updated%20DESC%2C%20summary%20ASC
 
Average of ratings: Useful (1)
math
Re: Atto misbehaving
 

Helen,

Hello! We met at the US Moot last year on the outing to the sculpture garden. A great adventure in public transit!

And thank you for the rapid reply. I had taken a quick look at the tracker site and at first didn't find anything similar. But with your link I found several items that may be related, but not exactly the same:

https://tracker.moodle.org/browse/MDL-46305. Describes problems with lists when the text is selected from the bottom up. In my case, direction of selection does seem to sometimes make a difference, but neither works correctly. Bottom to top or top to bottom - selecting  several lines of text and clicking either of the list icons generally places a bullet or number in front of the last bit of text in the editor - even if it wasn't part of the selection. Sometimes the bullet appears at the top of the list. But never more than one bullet, despite the number of lines of text selected.

https://tracker.moodle.org/browse/MDL-51872 deals with unordered lists not getting created correctly in IE 11, and the description of the behavior is very similar to one of the problems I am experiencing.

Both these are listed as unresolved.

More bad news. I did not realize it earlier, but, when text is selected, none of the formatting icons function as intended - bold, italics, justification, etc. If the tool is selected first - bold, for instance - then any further text input has that quality, but no formatting can be applied to selected existing text. There is odd behavior instead - the courser jumping to the last line of text, usually.

I am going through the process of removing Atto plugins, in reverse order of their installation, purge caches,  and re-testing. I should probably start a tracker issue? I've started writing up a description that follows the guideines.

It is hard to pinpoint at what point the problem occurred. Our self-hosted server was updated a few days ago, and I updated and installed several add-ons both just before and just after. Mainly Atto and Office 365 plugins. I am starting with removing the Atto plugins after reading this discussion in which the htmlplus add-on was reported as being the culprit.

Thanks - and, as always, all help is appreciated.

David

 
Average of ratings: Useful (1)
math
Re: Atto misbehaving
 

I have submitted this in the Tracker as https://tracker.moodle.org/browse/MDL-53326

 
Average of ratings: -
Picture of Mihai Bojonca
Re: Atto misbehaving
Testers

I got exactly the same issues. I need to try and remove all newly added plugins. But I cannot put the site in maintenance mode at the moment.

 
Average of ratings: -
math
Re: Atto misbehaving
 

Mihai,

I am sorry that you are having the same issue, but it is a little comforting to know that I am not the only one.

I haven't completed uninstalling all of the Atto plugins that I have added, just the last 3 or 4. This has not helped. I started the above tracer issue (I hope I did it right), but haven't seen any action on it, yet.

I was hoping that removing HTMLPlus would have done the trick - as reported in this discussion:

https://moodle.org/mod/forum/discuss.php?d=315260

It doesn't happen in all Atto instances. None of the modules' Description boxes are affected, for example.

Hopefully, we will get it figured out!

David

 
Average of ratings: -
Picture of Helen Foster
Re: Atto misbehaving
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTestersTranslators
David, regarding your tracker issue MDL-53326, for developers to be able to investigate the problem, they need to be able to reliably reproduce it on a standard site with no additional plugins installed, such as https://demo.moodle.net/.

If the problem can't be reproduced on a standard site, then it indicates that one or more additional plugins are causing the problem. Thus, as you are doing, you need to disable or uninstall plugins in order to determine which one is causing the problem. Once you've figured it out, it's a good idea to inform the plugin developer so that if they have time, they can investigate things further.

PS Thanks for reminding me about meeting at the US Moot last year. It brings back happy memories! smile
 
Average of ratings: Useful (1)
Picture of Daniel Thies
Re: Atto misbehaving
Core developersParticularly helpful MoodlersPlugin developersTesters

Currently the sandbox has Moodle 3.0.2 (Build: 20160111) so it will not show a recent regression. There are more recent fixes involving this; see MDL-53249 which was integrated this week.

Updating to the most recent release may fix the problem. I just upgraded, and I am not seeing it.

 
Average of ratings: Useful (3)
Picture of Mihai Bojonca
Re: Atto misbehaving
Testers

Dear Daniel, thank you for posting about the update.

I can confirm that the update fixed my issues.


 
Average of ratings: Useful (1)
math
Re: Atto misbehaving
 
Mihai,

Good news! I'm hoping to report the same shortly, as soon as our network folks can update to the latest build.

Thanks,
David
 
Average of ratings: -
math
Re: Atto misbehaving
 

Daniel,

Thank you for you comments and advice. And for the reference to MDL-53249 - it sounds like the same problem we are having. I will ask our network guys to apply the latest 2.9.4 build as soon as possible - and I'll report back here the result. I'm expecting the problem to be corrected, given your insight and Mihai's good report.

Thanks!

David

 
Average of ratings: -
math
Re: Atto misbehaving
 

Daniel,

You were absolutely right - upgrading to the latest weekly build fixed the formatting issues we were having. Thank you for pointing me in the right direction!

David

 
Average of ratings: -
math
Re: Atto misbehaving
 

Helen,

Thank you for the Tracker guidance - and it makes perfect sense. Is there a way for me to retract the issue I started?

And it appears that the issue has already been addressed in MDL-53249. I am hoping to get our network folks to update to the latest build right away.

I appreciate the help available through this community!

I do hope we cross paths again. I will be attending either the US Moot in Los Angeles or the Mountain Moot in Helena, Montana this summer.

Thanks, All!


 
Average of ratings: -
Picture of Helen Foster
Re: Atto misbehaving
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTestersTranslators
David, it's good to hear that your problem is most likely fixed in the latest 2.9.4.

I notice MDL-53249 is already linked to MDL-53326, so once you've confirmed that everything is working fine, please add a comment to MDL-53326 explaining that the problem is resolved by updating. A developer will then close the issue.
 
Average of ratings: Useful (1)
math
Re: Atto misbehaving
 

Helen,

Thank you for the guidance. I have just now added a comment to MDL-53326, noting that updating to the latest weekly build of 2.9.4+ has fixed the issue.

I do appreciate your help - and that of Daniel and Mihai. The community support in Moodle is incredible!

Take care,

David

 
Average of ratings: -
Picture of Helen Foster
Re: Atto misbehaving [Solved]
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTestersTranslators
Thanks David for your feedback, both here and in the tracker issue. It's good to hear that the problem is solved in the latest 2.9.4+. smile
 
Average of ratings: Useful (1)