Instalación y Actualización

Instalación moodle 2.9.3. problemas con el theme

 
Imagen de Jose Manuel Rufo
Instalación moodle 2.9.3. problemas con el theme
 

Buenos días a todos compañeros.

Estoy llevando a cabo la instalación de la versión 2.9.3. de moodle y me encuentra con el siguiente problema.

Al realizar la instalación todo se lleva a cabo con normalidad, los requisitos son todos correcto y no tengo ningún problema.

Sin embardo, al finalizar la instalación moodle no me cargar ningún theme.


¿Alguién sabría decirme porque puede estar ocurriendo esto?


Gracias de antemano a todos.


un saludo.


 
Promedio de calificaciones:Útil (1)
Josep Maria Tarruella
Re: Instalación moodle 2.9.3. problemas con el theme
 

A mi me sucedió exactamente lo mismo con la versión 2.9.1 y lo resolví siguiendo lo que te indico, especialmente en los servidores de 1and1 que es donde yo tengo alojado mi Moodle:

Para nuevas instalaciones partiendo de 0, hay que tener en cuenta que los servidores de 1and1 con el contrato de alojamiento, no admiten la configuración que por defecto trae Moodle en la activación de los argumentos slash.
Si estos argumentos se dejan activados por defecto, no se cargan correctamente los temas de Moodle.

Esto sigue pasando desde la versión 2.2 (que es por donde seguí después de la 1.9).

Cuando
se hacen cambios que aprovecha configuraciones anteriores en que este parámetro ya está desactivado, no hay problema porque la arrastra de la anterior configuración.

Para desactivar este parámetro y que todo te funcione perfectamente tienes que ir a:

ADMINISTRACIÓN ==>>  Servidor ==>> HTTP ==>> Usar argumentos 'slash':  desmarcar la casilla que por defecto viene marcada. Sales de administrador, cierras el navegador, vuelves a entrar y ya está!!.

Desconozco qué otros efectos tiene el tener esta casilla desmarcada, pero para lo que yo hago, todo me funciona a las mil maravillas. Tener en cuenta que estoy hablando de un sitio con menos de 200 usuarios y muy pocos curso que se renuevan constantemente. No hay acceso para invitados, por ahora.

Espero te sirva a ti y a toda la comunidad que tenga el mismo problema.

Saludos!!
 
Promedio de calificaciones:Útil (5)
Imagen de Jose Manuel Rufo
Re: Instalación moodle 2.9.3. problemas con el theme (SOLUCIONADO)
 

Estimado Josep Maria.

Gracias por tú aporte. Efectivamente el motivo es el que me has indicado.

Ya está solucionado.

Un saludo.

 
Promedio de calificaciones:Útil (1)
Josep Maria Tarruella
Re: Instalación moodle 2.9.3. problemas con el theme (SOLUCIONADO)
 

Gracias por comunicar que has solucionado el problema. Me alegra saberlo porque esto significa que a muchos otros les puede servir esta solución.

Debes tener presente que si a partir de ahora solamente haces actualizaciones de la versión instalada y funcionando correctamente, este problema no te aparecerá. Solamente se dará de nuevo si haces una nueva instalación partiendo de cero.

Saludos.

 
Promedio de calificaciones:Útil (1)
Imagen de Ana Olivares
Re: Instalación moodle 2.9.3. problemas con el theme
 

Hola, buenas tardes: 


Disculpa la ruta que indicas es desde Cpanel? o en dónde? 


Gracias

 
Promedio de calificaciones: -
Josep Maria Tarruella
Re: Instalación moodle 2.9.3. problemas con el theme
 

Esta ruta es desde que has entrado en Moodle como Administrador y entonces has de seguir por ADMINISTRACIÓN ==>>  Servidor ==>> HTTP ==>> Usar argumentos 'slash'

No se trata de Cpanel, no tiene nada que ver.  Se trata de entrar en Moodle con privilegios de administrador y entonces seguir la ruta que indico.

Y por cierto, estaría bien que si os resulta útil la ayuda, pues lo marquéis como útil, porque es un poco frustrante que se intente ayudar y ni siquiera se molesten en marcar la resolución como que ha sido de utilidad...

Saludos.

 
Promedio de calificaciones:Útil (6)
Imagen de Ana Olivares
Re: Instalación moodle 2.9.3. problemas con el theme
 

Hola Josep: 

Gracias por la información, lamentablemente yo ya no puedo acceder a mi Moodle, solo tengo un respaldo hecho en Cpanel y que estoy intentando restaurar. 

Mil gracias de todas formas por su tiempo.

Saludos

 
Promedio de calificaciones: -
Imagen de Gerardo Ubeda
Re: Instalación moodle 2.9.3. problemas con el theme
 

Hola Josep María. 

He sufrido el problema con una instalación de Moodle 3.0 en un servidor 1&1 y hasta que no he visto tu respuesta no había podido solucionarlo.

Ahora todo va bien. Muchas gracias.


 
Promedio de calificaciones: -
Imagen de Carlos Jesus Sanchez Ortega
Re: Instalación moodle 2.9.3. problemas con el theme
 

Muchísimas gracias Josep Maria Tarruella, me encontraba subiendo a mi hosting de 1and1 una moodle versión 3.0 y me encontré con este problema, de que no cargaba el tema.

Al ver que los permisos de los archivos estaban bien y las imagenes se cargaban sin problema. Llegue aquí.

Gracias por compartir tu solución.

Un cordial saludo.

 
Promedio de calificaciones: -
Imagen de Leire Gómez
Re: Instalación moodle 2.9.3. problemas con el theme
 

Muchísimas gracias por tu ayuda. Me estab volviendo loca para solucionar este problema.

He seguido los pasos que nos has dejado y solucionado.

Un saludo.

Leire Gómez.

 
Promedio de calificaciones: -