Moodle for mobile

How to enable Moodle Mobile App for all accounts

 
Picture of Nathan Smith
How to enable Moodle Mobile App for all accounts
 
Just wondering if anyone who has got the Moodle Mobile App (v2.2) to work with their Moodle site know what I'm doing wrong?


I have enabled the Webservices on my Moodle Site as per the Moodle Doc for enabling the Moodle Mobile App.

I as a site administrator can login to the App with no issues

When I try to log in as any other user (student, teacher or Manager) it throws the error message "Invalid response value detected"

Any help with this would be much appreciated!

Thanks,
Nathan

 
Average of ratings: -
Picture of Dani Palou
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hello Nathan,

can you send me a test account via private message so I can look into it? I need the Moodle URL, username and password.

Regards,

Dani

 
Average of ratings: -
Picture of Aurélien Stas
Re: How to enable Moodle Mobile App for all accounts
 

Hello Nathan, 

I have the same error message with my Moodle Mobile app. 

How did you resolve it? 


Thanks 

Aurélien

 
Average of ratings: -
Picture of Graham Stone
Re: How to enable Moodle Mobile App for all accounts
Testers

We are having the exact same problem here.

Thanks,

 
Average of ratings: -
Picture of Juan Leyva
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

Hi,

you can send us a test user account to mobile@moodle.com if you want us to debug the problem.

Every site is different, we've detected that this error may happen due to several reasons, for example, sites with data migrated from 1.9, sites using incorrect values in some global settings, etc...

Juan

 
Average of ratings: -
Picture of Dani Palou
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

The problem in Nathan's Moodle was that it had an incorrect value in userquota. As Admin, if you go to Site Administration > Security > Site policies there is a field named userquota that MUST be a number, it cannot have commas or spaces, that made the WS calls fail. 

As Juan said, there are several reasons why this might fail, if you can provide us a test account we can perform some tests.

Kind regards,

Dani

 
Average of ratings: Useful (1)
Picture of José Mata
Re: How to enable Moodle Mobile App for all accounts
 

I have a similar problem. User admin is the only one able to login. The userquota is ok in my case.

The authentication for all users but admin is external DB. I wonder if this could be the problem.


 
Average of ratings: -
Picture of Juan Leyva
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

Hi,

can you review the FAQ? https://docs.moodle.org/30/en/Moodle_Mobile_FAQ in some cases, doing a purge all caches works too

Juan

 
Average of ratings: -
Picture of José Mata
Re: How to enable Moodle Mobile App for all accounts
 

Hi Juan, I purged all caches but problem remains.

I wonder if db auth method is the problem, since all my users but admin authenticate on an external database.

Regards. 

 
Average of ratings: -
Picture of Juan Leyva
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

Hi,

can you check this?

Check that the ADOdb logging option is disabled if you are using the external database auth or enrolment plugin. (In Plugins > Authentication > External database and in Plugins > Enrolment > External database).

If is still failing, we'd need a test user account (send details if possible to mobile@moodle.com)

Juan

 
Average of ratings: -
Picture of José Mata
Re: How to enable Moodle Mobile App for all accounts
 

Hello Juan,

I just clicked on the capability createmobiletoken for the authenticated user as you indicated and the problem was solved.

Thanks a lot for your helpful support.

Regards.


 
Average of ratings: -
Picture of Juan Leyva
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

Hi,

it was the user quota problem again, the returned error was:

userquota => Invalid response value detected: Invalid external api response: the value is \" 1073741824\", the server was expecting \"int\" type"

It seems that in the global site settings you have a userquota value that is not an integer (notice that the first character is  a white space), you should change it to just "1073741824" (without the quotes)

Juan

 
Average of ratings: Useful (1)
Picture of Aron Kondoro
Re: How to enable Moodle Mobile App for all accounts
 

Hi Juan,

We have same problem with our Moodle mobile app. 
(Credentials removed for safety reasons).

Thanks in advance.

(Editado por Daniel Palou - envío original martes, 22 de diciembre de 2015, 16:38)

 
Average of ratings: -
Picture of Dani Palou
Re: How to enable Moodle Mobile App for all accounts
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi Aron,

I edited your message and removed the credentials for safety reasons, we always ask people to send them via e-mail or private message because making them public is always risky.

I tested the user you sent us and I'm able to access the app. What problem are you having exactly? I see that courses list is empty, but that's because the WS is returning an empty list so I guess the user is not enrolled in an course.

Kind regards,

Dani

 
Average of ratings: -
Picture of Aron Kondoro
Re: How to enable Moodle Mobile App for all accounts
 
Hi Dani,



Thanks alot, but I managed to fix the problem. It was the same issue with

the user quota. The field was empty so I just entered the default integer,

and now it works.



Kind regards,



Aron.
 
Average of ratings: -