Wiki

Unable to create a Wiki

 
This discussion has been locked because a year has elapsed since the last post. Please start a new discussion topic.
Picture of Jaap Marsman
Unable to create a Wiki
 

I am running into a strange error that I don't think is Moodle-related, but my-site related. I can't figure it out though and any help would be greatly appreciated! Below is some general information on my Moodle:

  • I'm running Moodle 2.8.7+ (compiled 2 days ago).
  • All modules and functionality in Moodle is correct (I can add, delete, use, etc everything).
  • The exception is using anything related to the Wiki module.
  • As soon as I create a Wiki, it gives me the "Invalid course module ID" error. If I create another module (for example, a book) this works flawlessly. However it refuses to run the Wiki module I created.

Things I've already tried:

  • I've got the same Moodle running on my MAMP installation and I was able to create a Wiki there. Oddly enough!
  • I've made a backup of the working Wiki on my MAMP and tried to restore to me server. No luck.
  • I've checked the MySQL database and all entries are correctly made into mdl_wiki. Both the MAMP and the production site have identical entries into mdl_wiki, so I do not understand the issue.

I am, quite frankly, completely stuck on how to solve this. The problem also existed on Moodle 2.8.7, hence the upgrade to 2.8.7+, which didn't fix the situation.

Thanks everyone for reading this post and any help would be greatly appreciated, since I'm eager to begin building some Wiki's! smile

 
Average of ratings: -
Picture of Jaap Marsman
Re: Unable to create a Wiki
 

I've fixed the issue by changing maximum allowed connections on the MySQL server side. Apparently the Wiki module is quite intense in this area, which caused a number of strange errors to appear.

 
Average of ratings: -