Piazzale Italia

Problema installazione Moodle 2.9

 
Immagine Luca Foscoli
Problema installazione Moodle 2.9
 

Sto cercando di installare moodle 2.9 sul server che ho a disposizione.

Quando l'installazione arriva alla "verifica del server" mi dà errore sul database mysql e al posto di OK mi indica "verifica".

Il motivo che dà è il seguente:

NomeInformazioniReportPluginStato
databasemysql (5.5.5-10.0.19-MariaDB-log)Versione minima necessaria: 5.5.31. Versione in uso: 5.5.5.10.0.19Verifica
La versione in uso è superiore alla versione minima richiesta ma non mi fa andare avanti.

Come fare?

Grazie.

 
Media dei voti:  -
Immagine Sara Cenni
Re: Problema installazione Moodle 2.9
Gruppo Core developers

Ciao Luca!

Non ho capito una cosa... Ma ti sta rilevando una versione diversa da quella installata?

Immagine Luca Foscoli
Re: Problema installazione Moodle 2.9
 

Mi sta rilevando la versione giusta (5.5.5) che è superiore alla versione richiesta (5.5.3) ma mi dice di verificare (non so cosa e come) per poter proseguire perchè non gli va bene. 

Però la versione attuale è superiore a quella richiesta e quindi dovrebbe farmi proseguire ma non so come fare ad andare avanti oltrepassando questo errore.

Immagine Sara Cenni
Re: Problema installazione Moodle 2.9
Gruppo Core developers

Se non leggo male nello screenshot la versione richiesta è 5.5.31

Immagine Luca Foscoli
Re: Problema installazione Moodle 2.9
 

5.5.31 come versione "minima". 

Se io ho la 5.5.5.10 che è superiore alla 5.5.31 dovrebbe far andare avanti ma non è così.

Hai in mente una possibile soluzione per provare a far continuare l'installazione con la versione che ho?

Immagine Sara Cenni
Re: Problema installazione Moodle 2.9
Gruppo Core developers

Secondo me 5.5.5.10 è comunque minore di 5.5.31 ;) dato che 5 < 31

Immagine Luca Foscoli
Re: Problema installazione Moodle 2.9
 

E' possibile, secondo te, comunque fare in modo che l'installazione NON verifichi questo e vada avanti ugualmente?

Immagine Sara Cenni
Re: Problema installazione Moodle 2.9
Gruppo Core developers

Ciao Luca,

il problema non è evitare il controllo ma capire il perché di quel vincolo... Non ho seguito le release di mysql quindi non so dirti le differenze tra le varie versioni, ma dato che sono specificate queste versioni di DB ( https://docs.moodle.org/dev/Moodle_2.9_release_notes#Database_requirements) io aggiornerei mysql per evitare problemi.

Ciao

Sara

Immagine Matteo Scaramuccia
Re: Problema installazione Moodle 2.9
Gruppo Core developersGruppo Particularly helpful MoodlersGruppo Plugin developers

Ciao Luca,
no non è consigliabile fare modifiche sui requirement di Moodle: hai provato a scegliere MariaDB e non MySQL in fase di installazione? Sebbene MariaDB sia un cosiddetto binary drop-in replacement di MySQL, è necessario che tu faccia la corretta selezione del database server in fase di installazione.

HTH,
Matteo

Immagine Matteo Scaramuccia
Re: Problema installazione Moodle 2.9
Gruppo Core developersGruppo Particularly helpful MoodlersGruppo Plugin developers

Ciao Sara,
lo sarebbe secondo i tuoi conti ma la versione di MariaDB lì indicata è la 10.0.19 ammiccante.

HTH,
Matteo