Security announcements

MSA-15-0013: Block title not properly escaped and may cause HTML injection

 
Picture of Marina Glancy
MSA-15-0013: Block title not properly escaped and may cause HTML injection
 
Description: It is possible to create HTML injection through blocks with configurable titles, however this could only be exploited by users who are already marked as XSS-trusted
Issue summary: Block title not properly escaped and may cause HTML injection
Severity/Risk: Minor
Versions affected: 2.8 to 2.8.3, 2.7 to 2.7.5, 2.6 to 2.6.8 and earlier unsupported versions
Versions fixed: 2.8.4, 2.7.6 and 2.6.9
Reported by: Gjoko Krstic
Issue no.: MDL-49144
CVE identifier: CVE-2015-2269
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49144