Security announcements

MSA-14-0036: XSS in mapcourse script in Feedback module

 
Picture of Marina Glancy
MSA-14-0036: XSS in mapcourse script in Feedback module
 
Description: Last search string in Feedback module was not escaped in the search input field.
Issue summary: XSS through $searchcourse in mod/feedback/mapcourse.php
Severity/Risk: Serious
Versions affected: 2.7 to 2.7.2, 2.6 to 2.6.5, 2.5 to 2.5.8 and earlier unsupported versions
Versions fixed: 2.8, 2.7.3, 2.6.6 and 2.5.9
Reported by: Petr Skoda
Issue no.: MDL-47865
Workaround: Disable feedback module or remove mod/feedback:mapcourse capability from users
CVE identifier: CVE-2014-7830
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47865