I uploaded the latest, but when running install.php got the following message
"Moodle 2.7 or later requires at least PHP 5.4.4 (currently using version 5.3.3).
Please upgrade your server software or install older Moodle version."
so deleted 2.7 and downloaded 2.6.4 and uploaded that.
However, still getting the same error message. I have checked and confirmed that our server is running PHP 5.3.3.
I tried clearing the Firefox cache and trying again, but the same thing happens.
Any advice welcome.