Security Announcements

MSA-14-0029: Cross-site scripting vulnerability in exception dialogues

 
 
My ugly mug
MSA-14-0029: Cross-site scripting vulnerability in exception dialogues
 
Description: Content of exception dialogues presented from AJAX calls was not being escaped before being presented to users.
Issue summary: Exception dialogs do not escape the content
Severity/Risk: Minor
Versions affected: 2.7, 2.6 to 2.6.3, 2.5 to 2.5.6, 2.4 to 2.4.10 and earlier unsupported versions
Versions fixed: 2.7.1, 2.6.4, 2.5.7 and 2.4.11
Reported by: Frédéric Massart
Issue no.: MDL-45471
CVE identifier: CVE-2014-3548
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45471