Security Announcements

MSA-14-0024: Cross-site scripting vulnerability in profile field

 
 
My ugly mug
MSA-14-0024: Cross-site scripting vulnerability in profile field
 
Description: Filtering of the Skype profile field was not removing potentially harmful code.
Issue summary: Persistent XSS Found
Severity/Risk: Serious
Versions affected: 2.7, 2.6 to 2.6.3, 2.5 to 2.5.6, 2.4 to 2.4.10 and earlier unsupported versions
Versions fixed: 2.7.1, 2.6.4, 2.5.7 and 2.4.11
Reported by: Osanda Malith Jayathissa
Issue no.: MDL-45683
CVE identifier: CVE-2014-3544
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45683