General help

Can’t insert image in Course/Site Summary Block

 
 
Picture of John D. Black
Can’t insert image in Course/Site Summary Block
 

I'm using Moodle 2.7. I'd like to insert an image in the Front Page Summary but can't figure out how. I've tried both Atto and TinyMCE text editors; no "Find or upload image” button appears. I've checked the text editor in course summaries, activities, etc. and the necessary button does appear in all those other locations.

I initially managed to drag-and-drop into TinyMCE. However, I needed to re-size the image and couldn't get DnD to work the second time around. I also tried putting the image in my private files and entering the URL, but that didn't work either.

Is this a bug that occurs only in the Course/Site Summary Block? Should I create a ticket? Can anyone think of a workaround?

 
Average of ratings: -
Mary Cooch
Re: Can’t insert image in Course/Site Summary Block
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

I'm not sure it's a bug as such, but it's always been like that. I've used images elsewhere online or else I have used a label with an image in (if I want the site summary in the centre) or a regular HTML block with image (if I want the site summary on the side)

 
Average of ratings:Useful (1)
Picture of John D. Black
Re: Can’t insert image in Course/Site Summary Block
 

Thanks, Mary.

I thought of adding a Label but ran into a snag there as well. Our v2.4 live site has a link for "Add an activity or resource." However, I can't find one in our v2.7 dev site. Home page editing is turned on. How do I get that link to appear?

Incidentally, our v2.4 site does have an upload button in the text editor for the Site Summary.

 
Average of ratings: -
Mary Cooch
Re: Can’t insert image in Course/Site Summary Block
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

Have you got "include a topic section" enabled in Front page settings? (Re text editor upload button, I don't have a 2.4 to check, but I haven't got one in 2.5...interesting...)

 
Average of ratings: -
Picture of John D. Black
Re: Can’t insert image in Course/Site Summary Block
 
Adding the Topic Section gave me the ability to add Activities & Resources. Thanks!

I think the missing upload is a regression. Do you want me to add an issue to the Tracker?
 
Average of ratings: -