PoodLL (plugin)

PoodLL Anywhere for Atto

 
Picture of Justin Hunt
PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

In the process of getting all the PoodLL mods ready for Moodle 2.7, I rewrote PoodLL Anywhere as a plugin for the new Atto html editor. The Atto html editor will be the default editor in Moodle 2.7.

It may be a few weeks yet before it is tested, approved and available on the Moodle plugins section. Till then you can get it from github here:

https://github.com/justinhunt/moodle-atto_poodll

(As usual you will need the PoodLL filter installed in order to run PoodLL Anywhere.)

 
Average of ratings: Useful (2)
Picture of Nicolas Dunand
Re: PoodLL Anywhere for Atto
Core developersParticularly helpful MoodlersPlugin developers

Hi Justin,

This is great, I was just looking for this exactly: not having to go through the file picker to add PoodLLs into Moodle text zones.

I just tested the atto_poodll plugin master version from GitHub (our interest is to record mp3 audio only, for now), and it works great! I hope it'll be approved soon in the Moodle plugins database, to make it easier to keep track of the updates.

 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

Me too! Thanks for the thumbs up.

 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

And its live on the plugins database now!! Thanks for waiting.

Here it is:

https://moodle.org/plugins/view.php?plugin=atto_poodll

 
Average of ratings: -
Picture of Chris Swaffield
Re: PoodLL Anywhere for Atto
 

I was able to install the poodll filter and the poodll anywhere for Atto plugin. I can not, however can not get the buttons to appear in the Atto toolbar. I've added poodll to the list in the area at bottom of the Atto toolbar settings, however it keeps producing the following error:

The line 'files = image, media, manage files, poodll ' is not in the correct format.

Any ideas why this would be the case? 

 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

I attached a screenshot of how my settings look. It could just be that you have split "managefiles" into "manage files." Does changing that make a difference?



 
Average of ratings: -
Picture of Chris Swaffield
Re: PoodLL Anywhere for Atto
 

So, I've been having a bit of an issue with poodll. Sometimes it wouldn't show in the list of filters, or sometimes it wouldn't show in the plugins. Odd. So, I uninstalled the filter and all of the modules that I had installed. Then I installed everything again (via git). Everything installed fine, but now I keep getting stuck at the 'plugins require your attention' page. The only option I have is to upgrade the database, but that throws an error saying the plugins cannot be downgraded. I don't want to downgrade them! How can I get around this page (see attached screenshot). 


 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

Some time back I moved all the Git repositories from Google Code to Github, because I wanted to fit in around here.  

I think you are probably pulling from the old repositories. You should all the PoodLL repos, and more, if you have a look at :

https://github.com/justinhunt/

Is that the issue?

 
Average of ratings: -
Picture of Chris Swaffield
Re: PoodLL Anywhere for Atto
 

Justin, 

Thanks for the response. I was able to resolve the issue with the online submission plugin by deleting it and installing it from the install plugins feature within Moodle. However, the same didn't work for the poodll recording question type. I've deleted that one, ssh'd into the server and verified that it was not there, then installed it via the install plugins feature within Moodle. I am still stuck at the same Plugins check screen. It is still  saying higher version already installed! How can I get rid of this error? Other than removing the plugin, what else should I do? When I go the Notifications page, it doesn't give me a notice of anything needing installation. 

 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

OK I see. I update the plugins on Moodle.org every few months, but on github it changes more regularly. I should have updated it more recently, but there was only a single change.

I updated the poodllrecording question type now on Moodle.org. I hope that solves it.

 
Average of ratings: -
Picture of Chris Swaffield
Re: PoodLL Anywhere for Atto
 

Justin  - yes, that did. I appreciate it very much!

 
Average of ratings: -
Picture of Blair Roy
Re: PoodLL Anywhere for Atto
 

Justin,

Thank you for posting this as it solved my problem with Poodll not showing up in the Atto toolbar.  We have just installed Poodll and are rolling out to our teachers this fall. We are very excited with all of the possibilities for use!

Sincerely,

Blair Roy

 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

Cool, I hope it works out well.

 
Average of ratings: -
Picture of Justin Hunt
Re: PoodLL Anywhere for Atto
Particularly helpful MoodlersPlugin developers

I attached a screenshot of how my settings look. It could just be that you have split "managefiles" into "manage files." Does changing that make a difference?



 
Average of ratings: -
Picture of andrea corleto
Re: PoodLL Anywhere for Atto
 

Hi Justin, just installed your useful plugin. It works fine, partially.... I mean, i can record audio mp3, draw and snap pictures but i can't shoot videos. Better, my webcam works, i can see my pretty face on the video, but buttons to record, play and stop are not active and i have a little yellow triangle with a beautiful exclamation mark warning me about a problem. Can you help me? Thanks

 
Average of ratings: -