Themes

Got a problem in elegance theme

 
 
Picture of japun balili
Got a problem in elegance theme
 

ahmm..  Guys, need help here so badly.

I'm only a beginner in using moodle and i got a problem using it.

Here's the story...

 

I was currently making my project in school. I have used several themes, i chose some good one, I even chose essential for it has a better look but when I saw elegance theme, I said wow. So i decided to use it. BUT when i changed the theme to elegance an error message showed, it says "Apache HTTP server has stopped working" . 

Anyone can help me?? please... please... please... I can't graduate in college if it can't be fixed. I already decided not to use other theme because I love this elegance theme ^_^.

I started to make my move to solve this matter and this one caught my attention. Is this "less" thing causes it?? Because I compared elegance to other themes and this "less" file is the only different. But i guess it's similar to CSS right? But it is only what I think, I'm only a "beginner" ^_^. So i need help. ehehe

 .. I have captured some pictures about this matter. Please see print screens for more information. ehehe.

By the way I'm working to this environment:

windows 8 OS, XAMPP control panel v3.2.1, moodle 2.6.1, elegance 2014041401(from github).

Thanks .. God Bless..

 

default themeessential themeI put the elegance folder in "theme" folder of moodleI clicked the change theme buttonI clicked the use theme buttonsad" width="1200" height="768" />sad" width="1200" height="768" />

 
Average of ratings: -
Gareth J Barnard
Re: Got a problem in elegance theme
Group DevelopersGroup Particularly helpful Moodlers

Hi Japun,

The words "I can't graduate in college if it can't be fixed" put this in a bit of a dilemma as any specific help could be seen by your tutors as plagiarism.  Also, you can graduate as unlike the commercial world, if it does not work then you can still describe what you did and how you tried to solve it and get full marks for it.  Your tutors will not be expecting a fully functional all singing all dancing program but rather that you demonstrate your abilities and problem solving / describing skills.  Ask your tutors about this for full disclosure of what you are doing.  It would be unprofessional of me to assist specifically without breaking the rules and code of academia.

Very generally if the Apache server has stopped working - i.e. no web page is produced but the service is running, then you are likely to be getting '500' errors.  This indicates a syntax fault so check your changes.

Gareth

 
Average of ratings:Useful (1)
Picture of Zac Mussatt
Re: Got a problem in elegance theme
 

I think that your best option is to restart.  Start fresh, and make notes of everything that you do.

If the problem happens again, then refer back to the last change you made.  I'm doubting that swapping to elegance caused the crash.

 
Average of ratings:Useful (1)
Picture of Andrew Downes
Re: Got a problem in elegance theme
 

I dont think elegance works on local host - you need to install it on a server. 

Feel free to reference me if you think that help might be plaigarism smile IMHO there's something very wrong with the realism of your assessment if asking for help on the internet is not allowed. I can understand issues with not referencing that help.

Andrew

 
Average of ratings: -
Picture of Richard Oelmann
Re: Got a problem in elegance theme
Group DevelopersGroup Particularly helpful MoodlersGroup Testers

I have elegance working on 3 or 4 local host instances, so localhost v server is not an issue.

There do seem to be a number of people experiencing issues with elegance, either this Apache issue or with Theme Designer Mode. I seem to have been very fortunate that I have not come across any of these with my set up at all. I've never had Apache crashing because of a theme change and I haven't experienced the issues with css not being fed correctly depending on Theme Designer Mode either.

As far as I know I haven't done anything special in installing it - I've cloned from github into my themes folder (at various times so various different versions) and applied it as the default theme and never had either of these issues. My local host instances (2.6 and 2.7Beta) run on Linux (Mint16), Apache, MySQL, while in work it (Moodle 2.6) is active on a Linux server which I believe is CentOS, Apache, PostGres.

 
Average of ratings: -
Picture of japun balili
Re: Got a problem in elegance theme
 
 
Syntax fault? But I just installed it, and filled up all the required fields.
 
Average of ratings: -
Gareth J Barnard
Re: Got a problem in elegance theme
Group DevelopersGroup Particularly helpful Moodlers

A 500 error is very hard to solve as could be anything.  So a syntax error could be files in the wrong place etc.  Could you post a screen shot of your '/theme/elegance' folder showing the files and folders please.

 
Average of ratings: -
Picture of japun balili
Re: Got a problem in elegance theme
 

SIr Gareth, these are the screen shots of my "elegance" theme's folder.



Are these okay???  Hope can you help me with this please... sir. I have more or less 2 weeks left for this project ehehehe... Please..


^_^ .. God Bless

 
Average of ratings: -
Gareth J Barnard
Re: Got a problem in elegance theme
Group DevelopersGroup Particularly helpful Moodlers

The folders look fine.

 
Average of ratings: -
Picture of japun balili
Re: Got a problem in elegance theme
 
Hi Gareth. I've tried "Bootstrap3" theme too in moodle2.7 and same result, same error.
Is my environment causing all this?? or is elegance good in win8??
 
Average of ratings: -
Picture of Hartmut Scherer
Re: Got a problem in elegance theme
Group Particularly helpful Moodlers

Hi Japun,

I am on Windows 8 with a local installation of Moodle 2.6 and 2.7. I can run Elegance only with theme designer mode on. In a different forum I read the advice to manually trigger cron (Site administration -> Notifications and click on cron.php maintenance script). 

My local installation is on Bitnami. In case you need to try it out, you can download the installation file HERE.

Regarding your server problem, I recommend the following steps:

- reboot your computer

- open File Explorer and go to xampp\ (you should see something that is similar to the screenshot below)

How to restart Apache Server

- double click on manager-windows or a similar file where you read "application" in the type column

- click on Manage Servers (2. tab)

- at the bottom of the new window, click on "restart all" and leave this window open

- open your Internet browser and start your Moodle installation

- if you see the error message again, you need to go back to the previous application (Apache Server) and click on restart again

Hope this works. If it doesn't I recommend installing the Bitnami-Moodle installation. 

With kind regards,

Hartmut

 
Average of ratings: -
Picture of japun balili
Re: Got a problem in elegance theme
 

Hello Hartmut,

Thanks for your help, but I really can't find that manager-windows "thing".

Can you please check this screen shot? smile

 
Average of ratings: -
Picture of Hartmut Scherer
Re: Got a problem in elegance theme
Group Particularly helpful Moodlers

Hi Japun, 

xampp_stop.exe will stop the server and sampp_start. exe will start the server. After you clicked xampp_start.exe, just minimize the window but leave it open. Now you should be able to use your local Moodle installation with the theme Elegance. As soon as you have access to your site, go to Notifications under Site administration and manually trigger the cron.php (click on the link, if it is still clickable). 

A few years ago I used xampp. As I had some difficulties with the installation on my PC, I was very glad when I found Bitnami. So in case restarting xampp doesn't help you, I highly recommend to uninstall xampp completely and install Moodle-Bitnami (see link in my previous post). The installation will be done in less than 30 minutes and is hassle-free. 

With kind regards,

Hartmut

 
Average of ratings: -
Picture of japun balili
Re: Got a problem in elegance theme
 

Thanks Hartmut, but maybe, I can't use Bitnami because I've already stated xampp in my thesis (technologies applied part) and I already passed it to my teacher.

But thank you very much, I'll try it out for testing. ^_^


-japun

 
Average of ratings: -
Picture of Zeid Fanous
Re: Got a problem in elegance theme
 

I just noticed that elegance doesn't work except with Theme designer on ...is this only for a local host.. i am using moodle 2.7 

 
Average of ratings: -
It's only an avatar...
Re: Got a problem in elegance theme
Group DevelopersGroup Documentation writersGroup Particularly helpful MoodlersGroup Testers

Apache needs kick starting when using Elegance theme, it does that with me too.

Do what Zac suggest and restart it.

As for graduating I had a similar problem with a database that suddenly stopped working which nearly lost me a grade. It turned out to be my own fault as I was asking the database to search on something that was not there! My tutor told me afterwards that I was the kind of person who could reverse an articulated vehicle into a small space, but did not know how to drive. The moral of that story is 'get to know the basics before you attempt to make changes'.

 
Average of ratings: -
Picture of japun balili
Re: Got a problem in elegance theme
 

o oohh ^_^

Thanks for the response guys!^_^

But for that "plagiarism" issue, I guess asking a help in the internet is not prohibited (as far as i know ^_^).

BTW, I'm just asking for help or a hint about this problem. Cause I know you guys are professionals. ehehe

But then, I'll try to restart what I've done. ^_^ Thanks.

 

 

P.S.

But any detailed help are so welcome. ehehehe 3smile

 

 
Average of ratings: -