Installation help

 
 
Picture of juice masters
Re: Error upgrading to 2.6
 

I tried using the godaddy server by creating a new database by importing my current 2.2.6 data then copied over the 2.6 files and updated the config file.  Once again everything went as planned until I got this message AGAIN;

quiz_grading

Error writing to database

More information about this error

It is usually not possible to recover from errors triggered during installation, you may need to create a new database or use a different database prefix if you want to retry the installation.

Debug info: Duplicate entry 'grading' for key 'mdl_quizrepo_nam_uix'
INSERT INTO mdl_quiz_reports (name,displayorder,capability) VALUES(?,?,?)
[array (
0 => 'grading',
1 => '6000',
2 => 'mod/quiz:grade',
)]
Error code: dmlwriteexception
Stack trace:
  • line 444 of /lib/dml/moodle_database.php: dml_write_exception thrown
  • line 1080 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
  • line 1122 of /lib/dml/mysqli_native_moodle_database.php: call to mysqli_native_moodle_database->insert_record_raw()
  • line 39 of /mod/quiz/report/grading/db/install.php: call to mysqli_native_moodle_database->insert_record()
  • line 486 of /lib/upgradelib.php: call to xmldb_quiz_grading_install()
  • line 1580 of /lib/upgradelib.php: call to upgrade_plugins()
  • line 431 of /admin/index.php: call to upgrade_noncore()

What on earth is causing this?  Why would the quiz table be causing such an issue?  I have marginal database skills but it seems like the 2.6 files are trying to overwrite the old quiz table but the old table is not allowing the overwrite.  Can anyone provide some insight into this problem?

 
Average of ratings: -