Installation help

Moodle 2.5 Windows 8.1 Incomplete Install

 
 
Picture of Nadim Khan
Moodle 2.5 Windows 8.1 Incomplete Install
 

Running Moodle2.5 + Windows 8.1 + IEv11. Installation is Standalone.

A blank page appears during the install process. This happens after the page requesting the Admin password change.

http://127.0.0.1/user/editadvanced.php?id=2

This is my second re-install with the same result.

Do I install with an older version of Moodle instead ?

Many thanks.

 

 
Average of ratings: -
Sketch...
Re: Moodle 2.5 Windows 8.1 Incomplete Install
Group Particularly helpful Moodlers

Reinstalling it a third time probably won't fix the problem. Rather, add the following code:

@error_reporting(E_ALL | E_STRICT);
@ini_set('display_errors', '1');
$CFG->debug = (E_ALL | E_STRICT);
$CFG->debugdisplay = 1;

above this line in your Moodle config.php file:

require_once(dirname(__FILE__) . '/lib/setup.php');

That will enable the debugging function in Moodle. You can then check the error messages that get triggered during the installations to see what the real problem is.

See http://docs.moodle.org/26/en/Debugging for more info on how to setup the debugging options.

 
Average of ratings: -
Picture of Nadim Khan
Re: Moodle 2.5 Windows 8.1 Incomplete Install
 

Thanks Luis. I've decided to re-install again. Do I apply the lines to config.php just before I commence the install process (i.e. when I kick off http://127.0.0.1 for the first time) or just after I hit the problem page again ?

 
Average of ratings: -
Sketch...
Re: Moodle 2.5 Windows 8.1 Incomplete Install
Group Particularly helpful Moodlers

You need to add the debug code to config.php before you "hit the problem page again" so that Moodle is able to display the error message when the problem reoccurs.

 
Average of ratings: -
Picture of Nadim Khan
Re: Moodle 2.5 Windows 8.1 Incomplete Install
 

I've applied the debug code and the page displays error:

"Fatal error: Maximum execution time of 30 seconds exceeded in Application\moodle25\server\moodle\lang\en\editor.php on line 26"

 
Average of ratings: -
Picture of Nadim Khan
Re: Moodle 2.5 Windows 8.1 Incomplete Install
 

This issue was resolved by updating php.ini and setting max_execution_time = 180.

Many thanks for the assisting.

 
Average of ratings: -