General plugins

How to install ELIS ?

 
 
Picture of david kao
How to install ELIS ?
 

How to install ELIS ?

Dose it support moodle 2.6 yet?

thank you!

  1. ELIS: on other possibility which might be worth looking into is ELIS which can provide a much more detailed course completion and outcomes management reporting tool (pulling data from across your site in regards to all courses enrolled).  ELIS is a much more powerful and complicated tool for providing user reports but might be worth checking out if you’re in need of something you can setup to provide ongoing access to specific metrics for any students.  Read more about its outcomes management tools here: http://rlcommunity.remote-learner.net/mod/book/view.php?id=24.  Find it available in the Mod Database at Moodle.org here: http://moodle.org/mod/data/view.php?d=13&rid=4894

 

https://github.com/remotelearner/elis.cm

 
Average of ratings: -
Picture of David Manning
Re: How to install ELIS ?
 

Just noticed your question. ELIS isn't for the faint of heart... you can get more details in this moodle thread. It involves patching using GIT. Once it's installed, you're on your own; there's no support community outside of remote-learner's documentation.

We're using it at our company for now due to its reporting and hierarchy features. We're on 2.5.3. My trials and tribulations are included in the thread. Good luck!

 
Average of ratings: -
Picture of Scott Karren
Re: How to install ELIS ?
Group Particularly helpful Moodlers

David and David,

Remote Learner has just released (well 18 days ago.) plugin based version of ELIS.  These plugins are much easier to install as they just need to be dropped in the appropriate folder in Moodle and then visit the notifications page.  The plugins are compatible with 2.6.2. The documentation as David Manning points out is on Remote Learners website, Make sure you read it very carefully.

I am testing these right now and they have worked very well so far. May be rolling them out within the next two months.

HTH

Scott

 
Average of ratings: -
Picture of gustavo Maurizio
Re: How to install ELIS ?
 

Dear Scott, thanks for your post. I find it very difficult to get these plugin versions. Would you be so kind as to point where are the files (i only seem to find the github older version) an how to install?

Thanks

 
Average of ratings: -
Picture of Scott Karren
Re: How to install ELIS ?
Group Particularly helpful Moodlers

Gustavo,

Remote Learner does a lot of development and puts much of their work out on GitHub, so you may need to scroll to find the specific plugins your looking for. Here is the link I follow to get to the repos https://github.com/remotelearner?tab=repositories.

You may find this link helpful as well, it is the most current manual for ELIS http://rlcommunity.remote-learner.net/mod/book/view.php?id=69

FYI, I have responded to your PM.

Scott

 
Average of ratings: -
Picture of Kim Lennon
Re: How to install ELIS ?
 
Sorry to ask a very simple question - but once I unzip the Stable 2.5 version, do I have to apply each patch manually or is there a script that I can execute that will automatically patch the code?
 
Average of ratings: -
Picture of Ron Meske
Re: How to install ELIS ?
 

We are just now in the process of installing and testing ELIS 2.6.1 version against a Moodle 2.7.1 installation.

In researching the best way to install we came across this article: http://www.thetravelingprogrammer.com/how-to-install-moodle-elis-2-6/

This uses git to download the plugins directly into the Moodle folder.

The process we used:

  1. Backup the db and the Moodle and Moodledata folders.
  2. Put Moodle into maintenance mode.
  3. Apply each of the plugins (we used git but you can also download the individual zips and then unzip into the appropriate folder).
  4. Login to your Moodle site to perform the setup/installation of the plugins.
  5. Take Moodle out of maintenance mode.

Hope this helps.


 
Average of ratings: -
Picture of Scott Karren
Re: How to install ELIS ?
Group Particularly helpful Moodlers

Ron,

I would love to hear how your testing is going.  I have been contemplating doing the same thing, We are currently using Moodle 2.4.4+ version and I want to get us up to the most current version.  If you are willing please share your testing results.

Scott

 
Average of ratings: -
Picture of Ron Meske
Re: How to install ELIS ?
 

Scott,

The install using git was fairly straight forward.  When accessing the site to initiate the plugin installation was also straight forward.

So in terms of the install, it was easy.  Now we're going through the documentation to determine how to actually make use of the features and configuration settings.  There is a lot to digest before we can even begin to work on use cases to test it.

Ron

 
Average of ratings: -
Picture of David Manning
Re: How to install ELIS ?
 

Hi Ron, 


How did you make out? 

 
Average of ratings: -
Picture of Ron Meske
Re: How to install ELIS ?
 

David,  Though there is a lot of documentation about the various components of the system there is not much in the way of how to use them together to create the functionality you are looking to create.  We have done a few sample setups in just learning how all the components work together.  We have taken a step back to look at what we want to do and document the different use cases.

We are documenting the following use cases from a business perspective:

  • Annual compliance training
  • Learning plans based on job type
  • Creating multitenancy for departments
  • Registering for classroom sessions

If anyone has a similar type of use case that is built out and willing to share, it would be appreciated.

 
Average of ratings: -
Picture of Alessandro Galli
Re: How to install ELIS ?
 

Dear Ron,


please I need of your help! I had followed the suggestion through the  article: http://www.thetravelingprogrammer.com/how-to-install-moodle-elis-2-6/ using the git to download the plugins directly into the Moodle folder but the worning / error coming from moodle set-up...

"Dependencies check failed for local_datahub, local_eliscore, elisfields_manual, elisfields_moodle_profile"

Under Requires

Moodle 201311801.11


Thank you in advance

Alessandro

 
Average of ratings: -
Picture of Ron Meske
Re: How to install ELIS ?
 

Alessandro,  

The link on that site for installing a combined Moodle and Elis we had errors with.  It installed a beta version of Moodle 2.8.

So, we installed on an existing Moodle 2.7 and did not encounter any problems.  Based on the error, I would check that you did install all components.

Ron

 
Average of ratings: -