Testing and QA

 
 
Julian Ridden
Issue with latest 1.6 upgrade
Group DevelopersGroup Moodle Course Creator Certificate holdersGroup Particularly helpful MoodlersGroup Translators

Grabbed the latest CVS code and have stumbled on one part of the upgrade and the following was generated. Any ideas how to fix?

(mysql): SELECT id FROM mdl_config_plugins WHERE name = 'field_map_city' AND plugin = 'auth/ldap'  

 



(mysql): UPDATE mdl_config_plugins SET value = 'Monte Sant' Angelo Mercy College' WHERE id = '48'  

 


1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'Angelo Mercy College' WHERE id = '48'' at line 1

         
      
   


Error updating Auth configuration auth_user_city to ldap field_map_city .
Thanks in advance
 
Average of ratings: -
Martin Langhoff - Sailing
Re: Issue with latest 1.6 upgrade
Group DevelopersGroup Particularly helpful Moodlers
For some reason the config_plugins table hasn't been created properly. What was your upgrade path? Does a clean install create it correctly?

Edit: Penny points out that I misfired. The problem is actually that my code isn't quoting the values correctly, and the single quotes around Monte Sant are breaking it.

I'll fix the code ;) In the meantime, your LDAP field mapping settings are invalid. You are supposed to put an LDAP field name there, not the actual value.
 
Average of ratings: -
Julian Ridden
Re: Issue with latest 1.6 upgrade
Group DevelopersGroup Moodle Course Creator Certificate holdersGroup Particularly helpful MoodlersGroup Translators

Thanks for the response Martin.

My upgrade path has been 'bleeding edge'. I download the CVS build about every 3 to 4 days and install.

I am upgrading from: 1.6 development (2005053000)

P.S. I am aware of what is meant to be in the field. Our LDAP does not store that data and I found this to be a quick nasty way to populate the fields automatically smile

 
Average of ratings: -
Martin Langhoff - Sailing
Re: Issue with latest 1.6 upgrade
Group DevelopersGroup Particularly helpful Moodlers
> I found this to be a quick nasty way to populate the fields
> automatically smile

This is beyond a nasty hack ;)

Anyway -- fixed upgrade path in 1.5 and HEAD.
 
Average of ratings: -