this is a heads up about the PHP version to be used as minimum requirement for Moodle 2.7 and upwards (to be released along May 2014). It’s being decided and discussed in the Tracker @ MDL-42931.
Basically, there are 2 options:
A) Moodle 2.7 to continue working with PHP 5.3.x
B) Moodle 2.7 to require PHP 5.4.x to work
Here there are some (4 for each, to be neutral and have them paired) positive facts about each option. You can find more details in the issue above:
A) PHP 5.3.x
- Right now, it seems to be the most used PHP version. (source)
- Some current (linux) distributions still come with it and some (not many, apparently) shared hosting companies still offer it.
- This does not affect to people already using PHP 5.4 and upwards.
- Upgrade to 2.7 and upwards will be easier if it does not involve upgrading PHP.
B) PHP 5.4.x
- It performs better and is securer than PHP 5.3 (new features aside).
- It’s maintained.
- Next (linux) distributions will include it (or newer PHP 5.5).
- Will allow to build a LTS (long term supported) version easier (no way to build it on top of an already EOLed PHP version).
And that’s all. For the records, we did a quick voting between HQ developers and results were 6 to 3 to upgrade to 5.4.x
Any thought will be welcome. Please, let’s discuss here about the PHP version only, keeping any other detail (databases, zlib…) into a separate thread.
TIA and ciao