Security and privacy

"Site policy URL for guests" keeps getting auto filled

 
 
Picture of Melissa Benson
"Site policy URL for guests" keeps getting auto filled
Group Particularly helpful MoodlersGroup Testers

Moodle version 2.5.1+

 

In the site policies section in the Moodle admin screens, there is a field for "site policy URL for guests" which keeps getting autofilled with "admin". I remove it, it resolved the issue of that message coming up and having to click "yes" to continue but a few weeks later the "admin" was filled in again. I remember this happening before last year.

 

Why is that autofilling? It's not like it autofills after every save..it seemed to have a few weeks later. We have not upgraded or anything.

 

Has anyone else ran into this issue? Ideas on what's going on?


 
Average of ratings: -
Picture of Marko Vidberg
Re: "Site policy URL for guests" keeps getting auto filled
 

Unless you have the line

$CFG->sitepolicyguest = 'admin';

somewhere in your config.php file, there is no reason it should be defaulting to such a strange value.  Maybe it is your browser populating the field somehow?  Try clearing your browser cache as well as pressing Purge all caches from the site administration -> development menu.

 
Average of ratings: -
Picture of Melissa Benson
Re: "Site policy URL for guests" keeps getting auto filled
Group Particularly helpful MoodlersGroup Testers

This is happening again to me. And this time it keeps autofilling to admin after saving. Ah! Any help?

 
Average of ratings: -
Just wondering . . .
Re: "Site policy URL for guests" keeps getting auto filled
Group Particularly helpful Moodlers

Tracker item: https://tracker.moodle.org/browse/MDL-45772

No known solution AFAIK

The coders are debating in geek speek

Serious geek talk here: https://code.google.com/p/chromium/issues/detail?id=352347

I really really dislike this bug

-Derek

 
Average of ratings:Useful (1)
Picture of Conn Warwicker
Re: "Site policy URL for guests" keeps getting auto filled
Group Particularly helpful Moodlers

The input might have the same name as the username field, so your browser is autofilling it. I get the same when I edit a course, it always fills the idnumber with my email address for some reason.

 
Average of ratings:Useful (1)
Picture of Melissa Benson
Re: "Site policy URL for guests" keeps getting auto filled
Group Particularly helpful MoodlersGroup Testers

Yep, I found that it autofills the courseid too! But what's weird is that it didn't always do that. Before it did, but I'd remove it and it'd still be removed. I tried going into firefox and it did not autofill.


My question is why would it autofill certain fields? I get that it's a browser thing but I feel like Moodle would have some sort of power to not autofill..I don't know.


I guess the solution is to open it in another browser and then save, so it doesn't autofill.

 
Average of ratings: -
Picture of Daniel Thies
Re: "Site policy URL for guests" keeps getting auto filled
Group DevelopersGroup Particularly helpful MoodlersGroup Testers
Using a different browser does not autofill because if no one has visited the form before with that browser. If it is set to autofill, then it remembers what you type in for the next time or for the next person after you to steal your information. 
One way to overcome this is to set the browser preference to not autofill. See for example  http://mzl.la/LRnhjb to disable on Firefox.
Another option would be to clear the cache and then open a "New Private Window" from the File menu which is not suppose to save or supply stored info to sites.
 
Average of ratings: -
Picture of Melissa Benson
Re: "Site policy URL for guests" keeps getting auto filled
Group Particularly helpful MoodlersGroup Testers

Thanks, Derek. So it looks like that "bug" is closed and it's a browser issue ( from my brief browse of the tracker item).


I found that when I went to firefox, it did not autofill. I also found that it did autofill courseid as well.

 
Average of ratings: -