General help

 
 
Picture of Robert Lavala
Bluehost Tech said, "Contact Moodle" - Help
 

So I'm just trying to upload a 30MB SCORM .zip file.

I've followed everything in the doc as far as changing the php.ini
> post_max_size
> upload_max_filesize
> increasing max_execution_time = 600
> Made sure that the LimitRequestBody is set high enough (according to Bluehost)

The Bluehost tech was online with me for 1 hour and made several changes including adding a .htaccess file and a few other things. At the end of the day I still get the error: The uploaded file may exceed the post_max_size directive in php.ini.

Any help would be truly appreciated.

 
Average of ratings: -
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

I thought that I would snoop around some more and while doing that I upgraded to the latest version of PHP single ini.

Once I did that I again changed the newly created php.ini file and the Site Admin/Security/Site Policies area changed to a 100MB limit. The only thing is it still gives the error about the file size being exceeded. My .zip is only 30MB.


 
Average of ratings: -
Picture of Jez H
Re: Bluehost Tech said, "Contact Moodle" - Help
Group Particularly helpful Moodlers

You need to check "Site Administration > Security > Site Policies" which I think is the one from your screen shot above.

Then you need to check "Site Administration > Courses > Course Default Settings".

Than check to see if the settings in your individual course (which can override the above).

Also check your php settings in "Site Administration > Server > PHPInfo".

There are two values you need to set in PHP:

  • upload_max_filesize
  • post_max_size

You need to make sure both of those are set high enough in php.

Hope that is of some use to you smile

 

 

 
Average of ratings: -
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

I checked all these variables and they all say, without exception: 100M.

Since I'm so new to Moodle (and doing anything with PHP) this is kind of overwhelming.

 
Average of ratings: -
Picture of Jez H
Re: Bluehost Tech said, "Contact Moodle" - Help
Group Particularly helpful Moodlers

To clarify, you went to:

"Site Administration > Server > PHPInfo"

Verified the values of:

  • upload_max_filesize = 100M
  • post_max_size = 100M

and still see "The uploaded file may exceed the post_max_size directive in php.ini"?

Have you tried uploading smaller files to test they work ok?

 
Average of ratings: -
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

I just did a 4M .zip upload and it is working fine. I'm going to try just over 10M - maybe 12M and then up until I reach the "limit". This is totally annoying. I would rather be creating content for sure.

 
Average of ratings: -
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

I've done a couple of tests and anything under 10M uploads fine. Going over that results in the error even though the moodle install says that the file size can be up to 100M.

Any more ideas?

 
Average of ratings: -
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

Bluehost tech support says, "It's something in the program limiting the upload size"

I've changed every php.ini file on the entire server to match at 500M.

I cannot upload a simple 15M .zip file yet. Anything under 10M works fine. Help... this is driving me crazy.




 
Average of ratings: -
Picture of Jez H
Re: Bluehost Tech said, "Contact Moodle" - Help
Group Particularly helpful Moodlers

Well this is a conundrum!

Your ini file looks correct so it does look like a Moodle setting.

You could try setting it to "Server Limit" instead of 500MB and see what that does.

Did you double check the settings inside the course you are uploading too? I know you said before you had checked all settings, but under the circumstances I thought it was worth double checking (screen shot below)

 

 

 

 


 
Average of ratings: -
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

Yes...  a problem within Moodle.

Every other setting is at Site Limit 500MB except for the course level... The course level setting ONLY is allowing for 10M as the max.

Maybe I should go back to a more stable version of Moodle? I'm brand new at this and this is becoming, well you know, frustrating.



 
Average of ratings: -
Picture of Jez H
Re: Bluehost Tech said, "Contact Moodle" - Help
Group Particularly helpful Moodlers

Hmm I have never seen that happen and cannot think what could be doing that other than the things already discussed.

I am not using Moodle 2.5 so cannot be sure things behave the same way as 2.4.

Rather than rolling back what you have, try adding on a subdomain and install a test copy of Moodle there, I would take the official 2.4.6 release, NOT the weekly build.

If you see the same issue in that build then it is most likely something on the host and you wont have wiped your current setup.

Dont give up on it, once you have it running Moodle is a great system smile

 
Average of ratings:Useful (1)
Picture of Robert Lavala
Re: Bluehost Tech said, "Contact Moodle" - Help
 

Thanks for the advise. How did you know I was ready to give up on Moodle. I just want something that works. Being frustrated by the platform hinders the creative stuff.

I'll try what you suggest but from what I've seen there are other folks with the same problem and so far there doesn't seem to be a solution presented.

 

 
Average of ratings: -
Picture of Jez H
Re: Bluehost Tech said, "Contact Moodle" - Help
Group Particularly helpful Moodlers

Well usually it does "just work", I think you have been somewhat unlucky.

Where are the other reports of this, are they in a bug tracker?

 
Average of ratings: -
Sketch...
Re: Bluehost Tech said, "Contact Moodle" - Help
Group Particularly helpful Moodlers

Something to try:

Make sure that there is only one php.ini file on your Moodle server. If there is more than one then the settings in one might override the settings in the other (if they aren't the same), depending on how your shared space on the server is setup.

 
Average of ratings: -
Picture of Alex 09
Re: Bluehost Tech said, "Contact Moodle" - Help
 

You might have to upload the php.ini file to various locations - I certainly have had to in the past. However, I can't remember exactly where I had to upload them to and just abandoned it in the end.

To get around large SCORM uploads I used a repository and FTP'd the files up, I then added them from the repository using the file picker. Once they were copied into the course I deleted the files from the repository.

 
Average of ratings: -