Moodle for mobile

 
 
Picture of David Perry
Cannot connect - this site must use 2.4 or above (error)
Group Testers

Hi Juan

One of our students says both her iPhones (4 and 5) get this message. It works fine on my phone.

If I tell her to go into Settings > Development on the app and enable remote debugging, will that send the debug information to you directly?

 
Average of ratings: -
Picture of Jackie Toth
Re: Cannot connect - this site must use 2.4 or above (error)
 

I am getting the same thing... iPhone works fine, iPad works fine, Android gets the message you described, another iPhone gets the message you described.

The site is absolutely at Moodle 2.4 and we are using official Moodle Mobile app.

 
Average of ratings: -
Picture of ivo neitzel
Re: Cannot connect - this site must use 2.4 or above (error)
 

I have the same problem with android. It worked fine 1-2 days and from now on I receive the same message: Cannot connect - this site must use ...

Moodle installed is 2.5, last stable version.

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect - this site must use 2.4 or above (error)
Group DevelopersGroup Moodle HQGroup Particularly helpful Moodlers

Very strange errors... I'm trying to release 1.3 version this next week with some improvements in the login system

I'll keep you posted

 
Average of ratings: -
Picture of Jackie Toth
Re: Cannot connect - this site must use 2.4 or above (error)
 

Juan,

Maybe this will help... the message "the site must use 2.4 or above" displays right after you see "authenticating".  When I got the error on my Android, I used the same login credentials as I did on my iPad where it was successful.

Other colleagues tried as well with the same login credentials - some successful - some not; some with iPhones; some with Android; some with Nexus.

 
Average of ratings: -
Picture of Edward Chen
Re: Cannot connect - this site must use 2.4 or above (error)
 

Hi all,

I also got same error message on my iphone and my colleagues Android devices with both Moodle Mobile ver. 1.3 and 1.3.1.
I am using two authentication backend on my moodle, local database and external authentication (with MS SQL server).

But not all accounts can't login through Moodle Mobile. Just only users existed in SQL server can't. The users existed in local database are fine.

I read Mobile Moodle FAQ and not sure that FAQ #5 means those three ways external authentication are not supported or ALL external authentication methods?

Any ideas?

I am running Moodle ver 2.5 on FreeBSD 9.1-R

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect - this site must use 2.4 or above (error)
Group DevelopersGroup Moodle HQGroup Particularly helpful Moodlers

Hi Edward,

it's strange, it should work. The app doesn't work only for plugins that performs some types of SSO.

Can I have a test user (inside the SQL server table) in your Moodle installation? This is the only way for doing some debugging

It is ok for you, you can send me via a private message the url, username and password

Regards

 
Average of ratings: -
Picture of Wes Matchett
Re: Cannot connect - this site must use 2.4 or above (error)
 

Our moodle site is having this same problem.  We are on ver. 2.5.1 and I have verified that web services is enabled and Enable web services for mobile devices is checked.  We only use manual accounts and external database for authentication.  These are all the items I have found in researching this issue that can cause a problem.  Is there something else I should check?  I can set up a test id if needed.

 

Thanks for your help

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect - this site must use 2.4 or above (error)
Group DevelopersGroup Moodle HQGroup Particularly helpful Moodlers

Your site URL has something "special"? I mean, I saw an error from a site that ended with two double slashes //

 
Average of ratings: -