Installation help

 
 
Picture of Bhavesh Jha
Re: Installation Problem 2.5.1+
 

Hi Guillermo,

First of all thanx for your useful reply.

I tried alot doing it through your 1st suggested way. but couldn't do it.

Thanks again for writing 2nd alternate way in advance. Now its working... smile

(Kindly N.B. I had icudt36.dll, icuin36.dll, icuuc36.dll which i pasted in apache/bin/)

But, I could only remove the curl error, rest two openssl & 

[intl]
intl.default_locale = es_utf8
intl.error_level = E_WARNING

error couldn't be resolved .Kindly suggest.

And now starting facing new "Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\moodle\moodlelib.php on line 8377 (varies).

 

regards,

Bhavesh

 
Average of ratings: -
Gmads
Re: Installation Problem 2.5.1+
Group Particularly helpful MoodlersGroup Testers

Hi Bhavesh,

I forgot that that is an old PHP 5.3.5 version, that's why the numbers of the dll files are different, but the process is the same, as you just confirmed. It's to know that it is working now.

About the intl extension, you just need to 1) enable the intl extension; 2) look for the [intl] text in php.ini and enable/set the directives as shown:

intl.default_locale = es_utf8
intl.error_level = E_WARNING

I don't recall having to do anything else to have the intl extension working. I'd say the same about the openssl extension, enabling it is all that's needed.

Anyway, I wouldn't worry much about the intl and the openssl extensions, as the messages were warnings, not errors. Moodle can work even if there are warnings, but it cannot work if there is at least one error.

About the execution time:

http://docs.moodle.org/25/en/Administration_FAQ#How_to_change_the_maximum_execution_time

I would recommend you to get familiar with the documentation pages:

http://docs.moodle.org/25/en/Main_page
http://docs.moodle.org/25/en/Installation

 
Average of ratings: -