Installation help

 
 
Picture of Bhavesh Jha
Installation Problem 2.5.1+
 

I am using 'xampp server 1.7.4' and trying to install 'Moodle 2.5.1+ (Build: 20130830)'. Getting three errors regarding php_extension
1) curl "enabled it by removing semicolon (;) in php.ini but still showing error check.(showing in red color)
2) openssl "enabled it by removing semicolon (;) in php.ini but still showing error check.(showing in yellow color)
3) intl "enabled it by removing semicolon (;) in php.ini but still showing error check.(showing in yellow color)

in my php directory there are two .ini files, changes done in both file but problem still persists. sad
Kindly guide stuck with the installation.

OS : Microsoft 32bit

lacal server: xamp 1.7.4 (compatible)

 

Regards,

Bhavesh

 
Average of ratings: -
Gmads
Re: Installation Problem 2.5.1+
Group Particularly helpful MoodlersGroup Testers

Hi Bhavesh,

The two .ini files you say are in your php directory, are they the php.ini-development and the php.ini-production files? If so, you do not need to modify them, they act as templates. You should copy one of them as php.ini and then modify this php.ini file as needed.

As you know, the different extensions are enabled by opening the php.ini file and removing the initial semicolon from the corresponding line, for example:

;extension=php_curl.dll        ; disabled extension
extension=php_curl.dll        ; enabled extension (without the initial semicolon

** For the intl extension, you should also set the intl.default_locale and intl.error_level directives:

[intl]
intl.default_locale = es_utf8
intl.error_level = E_WARNING

http://docs.moodle.org/25/en/admin/environment/php_extension/intl

** For the openssl, you only need to enable the extension.

http://docs.moodle.org/25/en/admin/environment/php_extension/openssl

** For the curl extension you should first try by only enabling the extension.

http://docs.moodle.org/25/en/admin/environment/php_extension/curl

Once you have done all the required changes, save the php.ini file and restart you web server.

If you still get any error messages regarding the cUrl extension, then:

1. Go to the php folder.

2. Copy the icudt49.dll, the icuin49.dll and the icuuc49.dll files.

3. Go to the Apache bin directory.

4. Paste the three files:

apache/bin/icudt49.dll
apache/bin/icuin49.dll
apache/bin/icuuc49.dll

Restart your Apache web server and retry your Moodle install process.

 
Average of ratings: -
Picture of Bhavesh Jha
Re: Installation Problem 2.5.1+
 

Hi Guillermo,

First of all thanx for your useful reply.

I tried alot doing it through your 1st suggested way. but couldn't do it.

Thanks again for writing 2nd alternate way in advance. Now its working... smile

(Kindly N.B. I had icudt36.dll, icuin36.dll, icuuc36.dll which i pasted in apache/bin/)

But, I could only remove the curl error, rest two openssl & 

[intl]
intl.default_locale = es_utf8
intl.error_level = E_WARNING

error couldn't be resolved .Kindly suggest.

And now starting facing new "Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\moodle\moodlelib.php on line 8377 (varies).

 

regards,

Bhavesh

 
Average of ratings: -
Gmads
Re: Installation Problem 2.5.1+
Group Particularly helpful MoodlersGroup Testers

Hi Bhavesh,

I forgot that that is an old PHP 5.3.5 version, that's why the numbers of the dll files are different, but the process is the same, as you just confirmed. It's to know that it is working now.

About the intl extension, you just need to 1) enable the intl extension; 2) look for the [intl] text in php.ini and enable/set the directives as shown:

intl.default_locale = es_utf8
intl.error_level = E_WARNING

I don't recall having to do anything else to have the intl extension working. I'd say the same about the openssl extension, enabling it is all that's needed.

Anyway, I wouldn't worry much about the intl and the openssl extensions, as the messages were warnings, not errors. Moodle can work even if there are warnings, but it cannot work if there is at least one error.

About the execution time:

http://docs.moodle.org/25/en/Administration_FAQ#How_to_change_the_maximum_execution_time

I would recommend you to get familiar with the documentation pages:

http://docs.moodle.org/25/en/Main_page
http://docs.moodle.org/25/en/Installation

 
Average of ratings: -