General help

 
 
Picture of Akram Lazkanee
Problem with updating the environment
 

I installed 1.9 on my website and updated it into 2.0.7 and everything worked fine

now i'm trying to update it into 2.1 or 2.2 and all the installation requirements are OK, but when i press update Component it says (Component is up-to-date) without changing anything

i tried it many times but always the same error happening

can anyone help please?  

 
Average of ratings: -
Picture of Ken Task
Re: Problem with updating the environment
Group Particularly helpful Moodlers

If I'm understanding correctly, that tool is for assessing your system to see if it *would* support the version of Moodle chosen in the drop down pick list.  Moodle does not yet have a tool to upgrade a version step built into Moodle UI (like Word Press or Joomla 2.x/3.x) but working towards that from what I've read.

Whatever process you used to upgrade from 1.9 to 2.0.x is still the same process when attempting to move to 2.1.x or 2.2.x.

Just one piece of advice ... do a complete site backup - code directory, data directory, and get an SQL dump of the DB *before* taking the next step upwards.

'spirit of sharing', Ken

 
Average of ratings: -
Picture of Akram Lazkanee
Re: Problem with updating the environment
 

that's what i'm doing here

i chose to upgrade into 2.1 or 2.2 and the list down there has a status (OK) in every line

when i press Update component after choosing 2.x from the menu the page refreshes and it did nothing !!

just a note (component is up-to-date) appear

and that's how i upgrade from 1.9 into 2.0.7 

Site Administration -> server -> environment and i chose 2.0.7 and pressed update and a note appear (update installed)

 

 
Average of ratings: -
Picture of Ken Task
Re: Problem with updating the environment
Group Particularly helpful Moodlers

"and that's how i upgrade from 1.9 into 2.0.7"  Well, that's news to me ... and the rest of Moodledom, I think.  Wish it did, but it does NOT update/upgrade the Moodle to the version you selected in the dropdown/pick list.

It refreshes cause it's checking for the existence of the items listed and checking to see if your system meets the requirements for the version of Moodle you selected in the dropdown menu. 

Set the drop down to version 2.4 or 2.5 and see what happens.  You should notice the requirements for MySQL change.  If nothing appears to change then it means you have a system that can support version selected.  It's just a systems checker! ;)

'spirit of sharing', Ken

 

 
Average of ratings: -
Picture of Akram Lazkanee
Re: Problem with updating the environment
 

yes it's refreshing and after refresh i pressed update and (before update) there was (1.9) option in the menu and after that it disappeared and the menu now begins with 2.0.7

i tried to check for 2.4/2.5 or 2.6 and it's giving me an error cuz 2.2 required for that's one 

 
Average of ratings: -
Picture of Ken Task
Re: Problem with updating the environment
Group Particularly helpful Moodlers

2.0.7 must be your version of Moodle.  No reason to check system for requirements for 1.9 any more as one cannot 'roll back'.  The check for => 2.4 isn't really an 'error' ... but it does inform your system cannot support or you cannot upgrade to those versions without first upgrading to 2.2.x.

Again ... it does NOT upgrade the Moodle version.  It is just a systems checker. ;)

'spirit of sharing', Ken

 
Average of ratings: -