Security Announcements

 
 
My ugly mug
MSA-13-0027: Access issue in Chat module
 
Description: Users were able to access a daemon-mode Chat activity without the required capability.
Issue summary: Missing privilege check in mod/chat/gui_sockets/index.php
Severity/Risk: Minor
Versions affected: 2.5, 2.4 to 2.4.4, 2.3 to 2.3.7, 2.2 to 2.2.10, earlier unsupported versions
Versions fixed: 2.5.1, 2.4.5, 2.3.8 and 2.2.11
Reported by: Francois Gauthier
Issue no.: MDL-39628
CVE identifier: CVE-2013-2242
Workaround: Use the Chat module without the daemon.
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-39628