Moodle community sites

 
 
Picture of Helen Foster
Moodle Docs upgrade
Group DevelopersGroup Documentation writersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Just to let you all know, Moodle Docs is being upgraded today to the latest stable version of MediaWiki. All the wikis will be unavailable for a few hours.

 
Average of ratings: -
C'est moi :-)
Re: Moodle Docs upgrade
Group Documentation writersGroup Particularly helpful MoodlersGroup TestersGroup Translators

Hi Helen,

Since the upgrade, some links (with parameters) are now KO.

For exemple, before the upgrade, these links where all OK :

But now, they send errors (appart the first one), and you have to use these (adding index.php?title=) :

Can something be done to "restore" the previous functionnality, or must i modify links done that way?

Exemples are from 2.5, but it's the same for other wikis...

Séverin

 

 
Average of ratings: -
Picture of David Mudrák
Re: Moodle Docs upgrade
Group DevelopersGroup Documentation writersGroup Moodle HQGroup Particularly helpful MoodlersGroup Translators

Hi Séverin

thanks for reporting this. However, I don't think it's a bug. Note that URLs like

  • http://docs.moodle.org/25/en/Special:RecentChanges&limit=500&days=30
  • http://docs.moodle.org/25/en/Special:AllPages&namespace=10

are not valid according to HTTP standards.The arguments part must follow after the "?" character. So the valid URL would be

  • http://docs.moodle.org/25/en/Special:RecentChanges?limit=500&days=30
  • http://docs.moodle.org/25/en/Special:AllPages?namespace=10

and that works as expected. I am sorry if the incorrect form worked in the past. But we are not going to support that buggy behaviour any more. You will need to update your links. Thanks for understanding.

 
Average of ratings:Useful (2)
C'est moi :-)
Re: Moodle Docs upgrade
Group Documentation writersGroup Particularly helpful MoodlersGroup TestersGroup Translators

Hi David,

Thanks for your (quick) answer, test, and explanation smile

I understand that URLs must conform to HTTP standards. And i could/should have checked that...

Links updated wink

Séverin

 
Average of ratings: -