Security Announcements

 
 
My ugly mug
MSA-13-0023: Permission issue in blog comments
 
Description: There was no check of permissions for viewing comments on blog posts.
Issue summary: Blog comment validation should verify that the user can view a post.
Severity/Risk: Serious
Versions affected: 2.4 to 2.4.3, 2.3 to 2.3.6, 2.2 to 2.2.9, earlier unsupported versions
Versions fixed: 2.5, 2.4.4, 2.3.7 and 2.2.10
Reported by: Dan Poltawski
Issue no.: MDL-37245
CVE identifier: CVE-2013-2082
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-37245