Moodle for mobile

Cannot connect: the site must use Moodle 2.4 or later

 
 
Picture of Jo Matthews
Re: Cannot connect: the site must use Moodle 2.4 or later
 

I'm having the same issue authenticating with both ldap and manual accounts.

we're using v243. I downloaded the app for android. Enable web services for mobile devices is enabled

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi Jo,

in this cases, I need access to your Moodle installation for doing some tests, if it's not a problem for you, I would need a user account in your Moodle site without any special privilege and not enrolled in any course.

If it's ok for you, you can send me the login information via a private message

Regards

 
Average of ratings: -
Picture of Arshad Hussanee
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi all, 

Anymore update i regards to this issue? We are running Moodle 2.5.3 - Iphone 5S login fine but but android Samsung note/S3 cannot. However, my android tablet asus transformer logged in fine. What going on there?

Shad

 
Average of ratings: -
Picture of stefan hoefler
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Maybe you can check via the chrome debug bridge which action is used by the login form? 

 
Average of ratings: -
Picture of Vani Bheemreddy
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi Juan,

I have the same issue, for both manual and ldap users. For security reasons, i cannot share a user account with you. Is there anything that I could do to test/analyse this issue myself? Probably some settings that are missing? BTW The webservices and mobile webservices are enabled. 

When I access the site from the app on andriod, it automatically changes to http. And after that i cant login. The error '..Unable to log in...Check the URL...The site must be moodle 2.4 or above...' is on these lines. I have moodle 2.6.

When the site is accessed from a mobile browser, I get a certificate issue. If i proceed anyway, I am able to login to it and view all the courses just fine, but this certificate prompt makes the user skeptical from using the site. BTW there is a valid certificate signed by a trusted certificate authority.  

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi,

the app doesn't accept untrusted certificates (self-signed).

If your mobile browser displays a certificate issue, the app is not going to work.

You should change your site certificate by one trusted by the Android browser

Cheers, Juan

 
Average of ratings: -