Moodle for mobile

 
 
This is me.  Deal with it!
Moodle mobile and labels
Group Testers

I just want to confirm that its not our site that is doing this.  We make use of labels quite a lot but on Moodle Mobile it appears that label content isn't displayed in the app.  Is this correct and if so is there anyway I can add the labels to the app?

Thanks

Kieran

 
Average of ratings: -
Picture of David Perry
Re: Moodle mobile and labels
Group Testers

Kieran, it's picking up labels I've put on a course page (we just have a test m2.4 site for trying features out, and the app) but it is truncating the label string and abandoning any images embedded in them (presumably to make the app faster if you aren't on wifi or a fast 3g / 4g connection).

I'm PMing you now.

 
Average of ratings: -
This is me.  Deal with it!
Re: Moodle mobile and labels
Group Testers

Cheers Dave.  Yeah I tried it and your correct - It displays them but strips out all formating and images.  What it doesn't do though is display the section summary unfortunatly.

 
Average of ratings: -
Picture of Juan Leyva
Re: Moodle mobile and labels
Group DevelopersGroup Moodle HQGroup Particularly helpful Moodlers

There is a bug open regarding this issue: https://tracker.moodle.org/browse/MOBILE-258

The Moodle side has been resolved for 2.4.4 (and 2.5 and onwards) so it will work fine for 1.3 (that will be released in June) once I fix the Mobile app side.

PS: When I talk about "Moodle" or "Mobile app" sides, you must understand that the Mobile app is a WebService client so some bugs can come from Moodle and anothers from the app itself

Regards

 
Average of ratings: -
Picture of David Perry
Re: Moodle mobile and labels
Group Testers

Thanks Juan. Your sides terminology makes sense, will keep future postings as clear as I can (I had to explain to a sales rep that he was mis-describing a component in web land the other week).

 
Average of ratings: -