Installation help

Mixed Moodle versions detected

 
 
Sketch...
Re: Mixed Moodle versions detected
Group Particularly helpful Moodlers

Yes, it's so simple! Assuming Moodle is installed in \Moodle:

  1. Stop IIS/Apache
  2. Rename your existing Moodle folder to e.g.: \MoodleOld
  3. Create a new \Moodle folder
  4. Put the new version of Moodle in that new \Moodle folder
  5. Make sure the new \Moodle folder has the same permissions as the old one
  6. Start IIS/Apache
  7. Upgrade Moodle

 

 
Average of ratings: -
Picture of Joey Barclay
Re: Mixed Moodle versions detected
 

I have tried everything I have seen on these old posts to try and resolve my issue. I have the same problem of the "Mixed Moodle versions" error page and I have tried to do the rename of old moodle folder create new one upload and unzip new version, etc... Nothing has worked. First problem is I am running Linux on a VPS using the Plesk panel hosted by GoDaddy. I am not able to access the server and run any command line utilities as they do not allow SSH. Their isn't even a Moodle folder, it is called httpdocs but even after that realization and renaming that to old and creating new httpdocs with new version of Moodle and copying over config.php, moodledata it still doesn't work. I also looked for the "search" folder to remove it, as a temp workaround, and I cannot even find a folder called "search" anywhere in httpdocs or even my moodledata folder. 

PHP version is 5.4 and I was trying to install 2.8. Obviously the error is a result of PHP scripts of different versions. (FYI: I hired someone to do this for me who had experience and he up and quit and I have been learning from the beginning as I have never has experience with Moodle prior to this. 

Anyway, I was finally was getting the "Session Handler is Misconfigured" error. Cleared local cookies and cache in two different browsers and then I got a blank screen so I thought I was closer but to try and resolve that I removed the "Cache" and localcache" folders from moodledata and now I am back to getting the session handler is misconfigured and no cookie or cache removal will do anything now. Seriously stuck in nowhere ville... Any assistance from anyone would be fantastic.

 
Average of ratings: -