Authentication

 
 
Picture of Fran San
Mail error with XAMPP update
 
Hello all,
 
We have a weird problem with my smtp configuration.
 
I updated my XAMPP version to 1.8.1 and copy moodle, moodledata and mysql folders into the new XAMPP folder. Server runs ok and there is no problems.
 
My moodle version is 2.3.2
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
 
The problem arise with my smtp configuration with gmail. I haven't modified any parameter on my moodle.
 
 
SMTP hostssmtphosts
 
SMTP securitysmtpsecure
NoneSSLTLS
 
SMTP usernamesmtpuser
mymail@gmail.com
 
SMTP passwordsmtppass
 
 
 
Besides I've changed on class.smtp.php and class.phpmailer.php port to 465 and I've added $host='ssl://'.$host; on Connect function.
 
I've added in php.ini 
 
SMTP = smtp.gmail.com
smtp_port = 465
 
 
Logs shows that:
 
 
CourseTimeIP addressUser full nameActionInformation
           
ECGcorner Thu 21 March 2013, 11:34 AM   Guest user library mailer ERROR: SMTP Error: Could not connect to SMTP host.
 
 
And in a debbug mode, the error shown is:
 

Tried to send you an email but failed!

More information about this error

Debug info: 
Error code: auth_emailnoemail
Stack trace:
  • line 467 of \lib\setuplib.php: moodle_exception thrown
  • line 91 of \auth\email\auth.php: call to print_error()
  • line 60 of \login\signup.php: call to auth_plugin_email->user_signup()
Output buffer: <pre> SMTP -> ERROR: Failed to connect to server: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? (1728473135) <br />SMTP Error: Could not connect to SMTP host. </pre>
 
 
Do you know what could be the problem?
 
Thank you very much!!
 
 
Best regards,
 
Average of ratings: -
Picture of Fran San
Re: Mail error with XAMPP update
 

I've solved the problem with this link

http://stackoverflow.com/questions/2098718/unable-to-send-email-through-gmail-using-phpmailer-v5-1

 

And I remove $host='ssl://'.$host; on Connect function.

 

Hope it serves smile

 

 

 

 
Average of ratings: -