Installation help

 
 
Picture of Claudio Ferraro
Visualization issue
 

Hello all,

I'm beginner about moogle platform smile

I have installed moodle platform on my Raspberry with LAMP server.

I have a visualization issue, I attach a snapshot.

The home page is not loaded correctly and all links in the home page doesn't work. 

For installation I have followed this guide http://docs.moodle.org/24/en/Installing_Moodle (Moodle 2.4 v)

Can you help me?

Thank you


 
Average of ratings: -
Picture of Aditya Kakodkar
Re: Visualization issue
 

Check your config.php file. Make sure that the path to Moodle root folder ($CFG->dirroot), web url ($CFG->wwwroot) and moodledata ($CFG->dataroot) is correct and the webserver has appropriate permissions to access the files.

Regards, Adi

 
Average of ratings:Useful (1)
Picture of Claudio Ferraro
Re: Visualization issue
 

Thank you Aditya

I checked my config.php and the ($CFG->wwwroot) was wrong.

But in my config.php not is ($CFG->dirroot) line. I have to add it? how do I configure it? Can you link me a guide about config.php for moodle 2.4?

 

Claudio

 

 

 
Average of ratings: -
Picture of Visvanath Ratnaweera
Re: Visualization issue
Group Particularly helpful Moodlers
Hi

$CFG->dirroot is not compulsory.

Since Raspbian is Debian, this might help http://docs.moodle.org/22/en/Installing_Moodle_on_Debian_based_distributions#Install_Moodle. Scroll down for an example config.php file.

BTW, standard Moodle 2.4 is way too heavy for RaspberryPi. See 'smallest moodle 2.3 server' https://moodle.org/mod/forum/discuss.php?d=208201.
 
Average of ratings: -
Picture of Claudio Ferraro
Re: Visualization issue
 

you're right, moodle 2.4 is very slow with RaspberryPi.

 

 

 
Average of ratings: -
Picture of Visvanath Ratnaweera
Re: Visualization issue
Group Particularly helpful Moodlers
Of course! Possibly due to the severe database load. Did you try 1.9.latest?

Even 1.6 still runs on current Debian. The only change necessary is:
===
Note: MySQL changed the syntax of CREATE TABLE in version 5.5. Instead of TYPE=MyISAM (or InnoDB) now you have write ENGINE=MyISAM. http://dev.mysql.com/doc/refman/5.5/en/myisam-storage-engine.html Moodle 1.6 crashed due to this. The needed changes are recorded in this patch. [???]
http://docs.moodle.org/22/en/Installing_Moodle_on_Debian_based_distributions
===
Sorry, no patch ready yet. You can try a directory wide search and replace.
 
Average of ratings: -