General plugins

Nanogong - Moodle 2.4.1 "Failed to Initialize Recorder"

Picture of Eric Katchan
Re: Nanogong - Moodle 2.4.1 "Failed to Initialize Recorder"


Can you replicate the issue?  If so, is it on a specific browser or all browsers.  My guess is that is is the java plugin for the browser.

I have had a similar problem and it seemed to be because of the browser, not nanogong.  I removed the java plugin from the browser, cleared my cache, closed the browser, than restarted the browser.  When I got to the page which requested the jar file, I received a browser warning indicating that java must be enabled, do i want it enabled?  I activate and the plugin worked.





Average of ratings: -
Picture of Russ H
Re: Nanogong - Moodle 2.4.1 "Failed to Initialize Recorder"

Thanks for the response, Eric!

Both computers were running the latest version of Java and were testing it in IE, Firefox and Chrome.

Strangely the computer that worked at first, stopped working after about 15 minutes and then started working again about 10 minutes later... with no changes to system (e.g., headphones remained plugged in) except for a refresh for each.

We am hoping the log may have a clue to the problem and will continue to dig. We'll experiment with the removal of the plugin from the browser that you suggested.

Average of ratings: -
Picture of AL Rachels
Re: Nanogong - Moodle 2.4.1 "Failed to Initialize Recorder"
Core developersParticularly helpful MoodlersPlugin developersTesters

Hi Russ,

In the past, I used to have a lot of problems with Nanogong "failed to initialize recorder" messages when giving quizzes with Nanogong audio in them. It was occasionally due to Java not being up-to-date, but the main cause, and it took me a while to realize it, was that my server could not handle the number of concurrent users that I had and we were getting a lot of time-out errors, which led to the "failed to initialize recorder" messages. Once I replaced my "old-in-years (7) and old-in-technology (single core cpu)" server, the only time I've had a Nanogong "failed to initialize recorder" message, is when Java needed updating and it needed to be re-enabled.

Hope this helps and you find your problem soon,



Average of ratings: Useful (1)
Picture of Russ H
Re: Nanogong - Moodle 2.4.1 "Failed to Initialize Recorder"

Hi Al,

That is really helpful and syncs with our situation. We have confirmed that out of date Java installs on the client end can cause a problem and the unpredictable errors being related to server overload makes sense as we are on a fairly old server temporarily. This will motivate a speedy transfer to the new server.

Thank you very much for the info and help,


Average of ratings: -