General plugins

New activity: Simple Certificate

Picture of Gustavo Ramos
Re: New activity: Simple Certificate

Hi Carlos

i Try to use SimpleCertificate in Moodle 2.7. Installation its ok,  but when i try to add a new custom certificate after complete all fields i have this error and debug info

Debug info:
Error code: codingerror
Stack trace:
  • line 111 of \lib\classes\event\calendar_event_created.php: coding_exception thrown
  • line 252 of \lib\classes\event\base.php: call to core\event\calendar_event_created->validate_data()
  • line 2255 of \calendar\lib.php: call to core\event\base::create()
  • line 2647 of \calendar\lib.php: call to calendar_event->update()
  • line 535 of \mod\simplecertificate\lib.php: call to calendar_event::create()
  • line 97 of \mod\simplecertificate\lib.php: call to simplecertificate_send_event()
  • line 113 of \course\modlib.php: call to simplecertificate_add_instance()
  • line 268 of \course\modedit.php: call to add_moduleinfo()
Output buffer: <br />< b>Warning</b>: mysqli::real_escape_string() expects parameter 1 to be string, array given in <b>C:\xampp\htdocs\capacitacion\lib\dml\mysqli_native_moodle_database.php</b> on line <b>881</b><br />< br />< b>Notice</b>: Undefined property: stdClass::$timestart in <b>C:\xampp\htdocs\capacitacion\calendar\lib.php</b> on line <b>2183</b><br /> 

Any chance to solve or upgrade to be compatible with 2.7 version of Moodle?

Thanks in advance

Average of ratings: -
Picture of Carlos Alexandre Fonseca
Re: New activity: Simple Certificate
Group Plugin developers
it's not compatiple with moodle 2.7 yet, and i don't know when i will do that, i think in june
but it was in plan

as you can see in :

Average of ratings: -