Resource types

 
 
Picture of Kevin Oldham
Not all resources available under "Add a resource"
 

After upgrading to 2.3 we noticed that many of our courses from 1.9.9 now only display "book, file, and label" when a teacher tries to use the "Add a resource" function.  It seems to be the same wether the activity chooser is on or off.  New courses created since upgrading are fine.

I have discovered that accessing the course as admin. all resources display correctly in the old courses.  However, accessing these courses as teacher we only see the 3 mentioned resources above.  The same teacher account can go to a newly created course and see all resources in the new course.  This seems to be the case with any teacher account.

To do more trouble shooting, I tried creating a new course on our test server.  Checked the resources list as a teacher. Everything displayed correctly.  Then imported a back up of one of our older courses and checked.  After the import, only the 3 are listed.

Is there a setting or database field that can be changed that will permit all resources to be displayed in all courses?  Is there a setting in the teacher account settings that might be restricting some resources from being seen in the legacy courses?  Could there be a setting in the resource activities themselves that would keep them out of legacy courses?

Any help that anyone can offer would be most appreciated.  Thanks in advance!

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Not all resources available under "Add a resource"
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

There are some new capabilites like mod/page:addinstance that control who can add instances of which type of activity or resource.

During the upgrade, those should all have been set to 'Allow' for roles like Teacher, so you should not have noticed any changes, but there may have been an upgrade glitch.

 
Average of ratings: -
Picture of Kevin Oldham
Re: Not all resources available under "Add a resource"
 

Thanks for the advice Tim.  I checked all of the mod/page:addinstance and made sure that they are set to "Allow" for teacher and course creator roles.  It still seems that teachers still see only 3 resources in these courses.

Since it only seems to be happening in the legacy courses, might there be a course level setting that is getting in the way?

Might there be something in the database uing Adminer to look for?

Thanks again.

 
Average of ratings: -
Picture of Amy Holland
Re: Not all resources available under "Add a resource"
 

Hi,

I am also interested in this. We have just upgraded our test environment from 1.9 to 2.3 and noticed the same thing. However, we also have some activities missing as well.

I have attached images below of the different between the legacy courses and the newly created courses.

 



 
Average of ratings: -