Authentication

 
 
Picture of Josh Straughn
Interestingly only one LDAP user can login
 

This is strange to me.  I was able to successfully configure my LDAP settings and got my test account logged in.  Added my test account to the moodle editors group and logged in to see if he got the editing tools and he did.  Then I sent the link to my training department and they were not able to login as themselves.  So back to work I go and the only account that is getting logged in is the test account i made in AD.  I have deleted the account and that test user is able to recreate just fine authenticates off the AD User and Pass.  If i move the account in AD moodle says he cant login, move it back to the right OU and boom he works but no other accounts seem to be able to log in.  The ad server is win 2003.  Any ideas

 
Average of ratings: -
Picture of Iñaki Arenaza
Re: Interestingly only one LDAP user can login
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Hi,

I suspect this is because you have specified 'cn' as the 'User attribute' LDAP setting. If you want your users to log into Moodle using their Windows account usernames (the same username they type in the login screen of Windows), then you should specify 'samaccountname' instead of 'cn' (as is suggested in http://docs.moodle.org/24/en/LDAP_authentication#User_lookup_settings)

Saludos. Iñaki.

 
Average of ratings:Useful (1)
Picture of Josh Straughn
Re: Interestingly only one LDAP user can login
 

Thank you very much. I was driving home last night and it was plaguing me when i though.  My test user's user and acct name are the same, I wonder if that makes a difference.  I came in this morning and logged in with my full name and it worked.  Thank you for the reference to correct the cn field.  Have a wonderful day. 

 
Average of ratings: -