Installation help

 
 
Picture of Massimiliano Ragazzi
Problem install moodle
 

Hi

i've lampp 1.8.1 (Apache 2.4.3, MySQL 5.5.27, PHP 5.4.7), on ubuntu 12.10 (but i've tried fedora 18 too)

Doing the web installation of moodle it says i nedd php zip extension.

I've just tryed many solution like pecl installation with ni success.

pecl install zip

terminate with

/usr/include/php5/ext/pcre/php_pcre.h:29:18: fatal error: pcre.h: No such file or directory
compilation terminated.
make: *** [php_zip.lo] Error 1
ERROR: `make' failed

Someone can help me

many thanks for your efforts

Max

 
Average of ratings: -
Picture of Ken Task
Re: Problem install moodle
Group Particularly helpful Moodlers

It's a php extension you seek.

For Ubuntu try:

apt-get install php5-*

if apt-get won't do * then:

apt-get install php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

Fedora 18 uses yum still, I think:

yum -y install php5 php5-*

'spirit of sharing', Ken

 
Average of ratings:Useful (1)
Picture of Visvanath Ratnaweera
Re: Problem install moodle
Group Particularly helpful Moodlers
The last time I tested Ubuntu (Debian) php5 package came with zip built in. See http://docs.moodle.org/22/en/Installing_Moodle_on_Debian_based_distributions#PHP_Modules.

Looks like the LAMPP system doesn't have it. My advice is to install LAMP directly from the Ubuntu (Debian) packages as documented above. The XAMPP people warn against using it in a production environment.
 
Average of ratings: -