Glossary

 
 
Picture of José Carlos Gallego Cano
Glossary auto-linking for uploaded files doesnt work (Moodle 2.x)
 

Hi! Glossary auto-linking for uploaded files doesnt work.

I have this config in my Moodle site:

- Site administration > Plugins > Filters > Manage filters > Glossary Auto-linking : Active (On) | Applied To (Content)

- Site administration > Plugins > Filters > Common filters settings > Filter uploaded files (All files)

- Course administration > Filters > Glossary auto-linking (Default - On)

Glossary autolinking is working fine in Pages (as resources) and Forums, but not in Files (as resources) nor SCORMs.

Thanks a lot for your help!

 
Average of ratings: -
Picture of Joseph Rézeau
Re: Glossary auto-linking for uploaded files doesnt work (Moodle 2.x)
Group DevelopersGroup Particularly helpful MoodlersGroup TestersGroup Translators

Hi José,

Autolinking used to work for HTML uploaded files in Moodle 1.9 (and previous versions). I have never used SCORM, so I cannot say if it worked for SCORM in Moodle 1.9. Did it work for you? See this discussion.

Unfortunately in Moodle 2 autolinking no longer works in uploaded HTML files.

This bug completely ruined my Moodle courses, which were based on uploaded HTML files containing lots of words needing autolinking to the course glossary. Fortunately (for me), this happened just when my university switched to Moodle 2 and at the time I retired from my teaching job! However, I am surprised there have not been more protests at this regression since Moodle 2 has gradually superseded previous versions.

Reported as bug MDL-37830 for which you may vote.

Joseph

 

 
Average of ratings:Useful (1)
Picture of Martin Fischer
Re: Glossary auto-linking for uploaded files doesnt work (Moodle 2.x)
 

Hy Joseph and José,

I miss autolinking for uploaded files, too. Ijust didn´t know it ever worked.

Martin

 
Average of ratings: -
Picture of José Carlos Gallego Cano
Re: Glossary auto-linking for uploaded files doesnt work (Moodle 2.x)
 

Hi again, Joseph and first of all, thanks a million.

You are correct. I worked with static links into SCORMS in Moodle 1.9 and it worked fine. Then, I updated the version of PHP and headaches started. I applied the patch you mentioned and all become ok.
In Moodle 2.x that patch is still required but, as you say, the HTML links to uploaded files are dead.
I do not understand why the option is not available if it does not work ...
Indeed, in some web pages explain how to activate the auto-link and it seem to work for them .... What am I doing wrong?

I've more than 500 courses with several SCORMs and HTML pages. Remove static links from SCORMs and find an alternative to glossary in uploaded files will be a nightmare.

Any solution from official Moodle staff?????????

 
Average of ratings: -