Quiz

OU DnD question types with 2.4.1

 
Just wondering . . .
OU DnD question types with 2.4.1
Particularly helpful Moodlers

EDIT: please put this on hold - unless you have a specific bug report.  Tim has posted in the plugin forum (even thought it is late where he is) and there is good news. - D
=======================================

Just curious on the state of this.

  1. Jamie said these questions were OK here: https://moodle.org/plugins/view.php?plugin=qtype_ddwtos
  2. BUT: an error was reported here: https://moodle.org/plugins/view.php?plugin=qtype_ddimageortext  (But there was no follow up and maybe it was a false alarm?)

Our server was upgraded yesterday to 2.4.1+.  I have some problems.  But simultaeously we ran out of space, which may account for them.  

A comment from someone to say 2.4 + OU "DnD is working for them would be nice" - if not, if OU DnD + 2.4 is broken, then we need to get tracker items sorted ASAP to help the coders.  Once I get more space I'll be switching on debugging and having a further look.

-Derek

 
Average of ratings: -
Picture of Jamie Pratt
Re: OU DnD question types with 2.4.1
Core developersDocumentation writersPlugin developers

I just gave the dd word to sentence, dd image or text to image and ddmarker a quick run through and they all seem to work great on my dev instance of Moodle that is now running Moodle 2.5. As I said previously in the plug ins db the 2.3 version *should* work fine in 2.4 and 2.5 since there have been no changes to the api that would affect how they work. Although it looks like the YUI code library in Moodle has been upgraded to version 3.8 this does not appear to have broken anything. If there is some breakage would be very helpful if someone could describe the problem. Have just looked in the tracker though and it does not appear we have components for these new question types yet. So you could report any issues here in this discussion for now and I will look into creating components later today.

 
Average of ratings: -
Picture of Jamie Pratt
Re: OU DnD question types with 2.4.1
Core developersDocumentation writersPlugin developers

Ah, actually bugs should be filed in the tracker in the Non - core contributed plugins project in the 'Question Type: {none of the above}' component.

Would be a great help if people could file detailled bug reports of any problems they encounter. Including what browser they are using if it appears to be a js problem.

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: OU DnD question types with 2.4.1
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

That is what I was expecting to find when I tested this myself.

Please not that they may be bug-fixes in the code at github.org/moodleou that has not been uploaded to the Moodle plugins DB. (I must do something about that some time, probably after I have tested on 2.4 myself.)

 
Average of ratings: -
Just wondering . . .
Re: OU DnD question types with 2.4.1
Particularly helpful Moodlers

OK, for what it is worth.  I still have no joy getting the offending server and it's Friday and won't get sorted until Monday enough to do proper tests with the questions, but I have just used another server I have had access to.

Result: for text onto image and text onto text both created questions OK and the previews worked.  I think this is good news.  I stopped there.  Off to have a weekend.

Moodle: Moodle 2.4.1+ (Build: 20130125)

DnDText to Text: 2012081600

DnDText to Image: 2012081600

Thanks Tim, thanks Jamie.

 
Average of ratings: -