Installation help

 
 
Picture of Scott Karren
Re: GIT questions and insight needed
Group Particularly helpful Moodlers

Tim

Thank you for the quick reply and the information.  Please forgive my ignorance here, I am trying to understand what I am trying to understand.

I tried the new command and it returned this error "Cloning into 'folder'... fatal: Remote branch MOODLE_23_STABLE not found in the upstream origin"  Is this saying that I do not have a Moodle 23 stable branch created?  If I do a git Status I get "On branch MOODLE_23_STABLE nothing to commit, working clean directory"

So, digging some more and doing a git remote -v I see that origin is the name of the git repository at git.moodle.org, but I am still not understanding why I am getting the error that I am.  I changed to my moodle directory and did a git pull and it pulled the latest 2.3.4 changes down.  What am I missing and you can be brutally honest if you need to be, computer screens hide tears quite well.

Thanks

Scott

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: GIT questions and insight needed
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

It would help if you could tell us which add-on you are trying to install.

When you type git remote -v in the mod folder, that will show you the remote where you downloaded Moodle from. Not the remote where you tried to download the add-on from.

 
Average of ratings: -
Picture of Scott Karren
Re: GIT questions and insight needed
Group Particularly helpful Moodlers

Ok time for specifics, no more hand grenades and horseshoes.  The add-ons that we use are as follows:

Certificate, Questionnaire, Configurable Reports, ILP, Navigation Buttons, OneTopic format, and the Face to Face add-on.

We also use ELIS and a custom theme.  Thank you for your help in getting a hack more informed.

Scott

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: GIT questions and insight needed
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

That is not very specific. Which one of those plug-ins gives you the error about there not being a 2.3 stable branch when you try to install it?

 
Average of ratings: -
Picture of Scott Karren
Re: GIT questions and insight needed
Group Particularly helpful Moodlers

My apologies.  The one that I have tried to install is the Navigation Buttons. I wanted to successfully install one before moving on to the rest.

Scott

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: GIT questions and insight needed
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

So, look at https://github.com/davosmith/moodle-navbuttons. You will see that there is only a master branch and a MOODLE_19_STABLE branch, so presumably you need to install the master branch if you are any Moodle 2.x. The readme file there confirms that hypothesis, although it could be more explicity.

So, just do a git clone of that repository.

 
Average of ratings: -