General developer forum

 
 
Picture of jaswanth krishna
Moodle Migration Issue - 2.4.1
 

Hi Moodlers . 

till now i am using moodle 1.9 version . Now i wanted to migrate to moodle 2.4.1 , few of my already using custom plugin are based on on 1.9 . Now i do see few things have been deprecated in moodle .

I do have few questions related to 2.4.1

 

1) is 'page_base' been replaced with 'moodle_page' .

2) Having hard time in using  'page_map_class' . Do we have any alternative for that class or am i calling it wrong. 

3) Can anyone tell me how can i restrict teachers . I am using isteacherinanycourse  -- which is deprecated again . Should i go to get_roles_with_capability() ? 

It would great help if you guys can help me to sort it out 

 

Thanks,

Jaswanth

 

 
Average of ratings: -