General plugins

Warning messages with Topcoll and latest Moodle 2.4.1+