General help

 
 
Picture of Janno Bend
Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
 

Hello Community,

I´m absolutely clueless.

I can´t upload files larger than 15mb on moodle 2.4.1.
Moodle 2.3 works just fine.

If I try to upload a file via drop box, I get this error:
serverconnection,error
(Text above drop box sais: Maximum size for new files: 862.9MB)


If I try to upload the file via file picker I get this error:
Invalid JSON string


I´m running moodle LAMP on CentOS 32gb Ram.


php.ini includes:
post_max_size    1024M
memory_limit    1024M
max_execution_time    600


Thanx 4 your help wink
Janno

 
Average of ratings: -
Picture of Howard Miller
Re: Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Have you tried this with a different browser (e.g. Firefox or Chrome if you are using IE)?

You are absolutely sure that your maximum file upload is set to greater than 15MB?

 
Average of ratings: -
Picture of AL Rachels
Re: Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
Group DevelopersGroup Particularly helpful MoodlersGroup Testers

Hi Janno,

What do you have set for the Moodle default maximum upload size under Site Administration > Courses > Course default settings > Maximum upload size?

Also, what type of activity/assignment are you doing the upload with? Have you checked its Edit Settings > Submission settings > Maximum submission size?

Hope this helps,

AL

 
Average of ratings: -
Picture of Janno Bend
Re: Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
 

Hi guys,

thanks for your fast response.

I have tried to upload the files under IE and FF (different versions) on Windows 7 and Windows 8. I always get the same error. I don´t have chrome.
I doesn´t matter where I upload the file (course or maybe personal filespace).
I don´t know if it´s exactly 15mb. I think its between 15 and 20mb. Definitly above 20mb.

 Site Administration > Courses > Course default settings > Maximum upload size? 1gig
I cant find: Edit Settings > Submission settings > Maximum submission size
but the course maximum upload size is 1gig too.

/moodle/admin/phpinfo.php
says:
memory_limit    1024M    1024M
post_max_size    1024M    1024M
upload_max_filesize    1024M    1024M
max_execution_time    600    600


I will do a clean install on a different server to track the problem. I will post the results here.

 
Average of ratings: -
Picture of Janno Bend
Re: Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
 

Problem solved.

If you´re running Plesk, the PHP support run as shouldn´t run as fastCGI application. It must be APACHE module. FastCGI (default configuration) gives you only erratic behavior such as blank pages after install, canceled installations and lots of other problems.

File upload works now fine too.

 
Average of ratings: -
Picture of Ingeborg (Inky) Chandler-Mertz
Re: Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
 

I have exactly the same problem. Everything was fine yesterday and today I cannot upload anymore. Only small files. Very strange.

 
Average of ratings: -
Picture of Francisco Azcunaga
Re: Error [[serverconnection,error]] with fileupload > 15mb Moodle 2.4
 

Hi Janno, I have exactly the same problem you describe in a freshly installed site using the following guide:

 

https://www.digitalocean.com/community/articles/how-to-install-moodle-via-git-with-postgres-nginx-and-php-on-an-ubuntu-12-04-vps

 

This uses fastCGI which you recommend to disable --- are you sure this is the only way?? I understand nginx and fastCGI are a fast setup for Moodle.

 

Many thanks,

Francisco

 
Average of ratings: -