Installation help

 
 
Picture of Mydnyte Syn
Installation Issues 2.4.1+
 

I'm trying to install Moodle 2.4.1+ so I can learn to use for a client who wants to use the software.  However, I can't get the install to finish.  Here's some background info:

cPanel Version 11.34.1 (build 7)
   
Apache version 2.2.17
PHP version 5.3.6
MySQL version 5.1.66-cll
Architecture i686
Operating system linux
   
   
   
Perl version 5.8.8
Kernel version 2.6.18-308.24.1.el5
cPanel Pro 1.0 (RC1)  

I keep running into the following errors:

 

NameInformationReportStatus
unicode   must be installed and enabledmust be installed and enabled

It is required that you store all your data in Unicode format (UTF-8). New installations must be performed into databases that have their default character set as Unicode. If you are upgrading, you should perform the UTF-8 migration process (see the Admin page).

Check
php_extension intl should be installed and enabled for best resultsshould be installed and enabled for best results

Intl extension is used to improve internationalization support, such as locale aware sorting.

Check
database mysql version 5.1.33 is required and you are running 5.1.66version 5.1.33 is required and you are running 5.1.66 OK
php   version 5.3.2 is required and you are running 5.3.6version 5.3.2 is required and you are running 5.3.6 OK
pcreunicode   should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension iconv must be installed and enabledmust be installed and enabled OK
php_extension mbstring should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension curl must be installed and enabledmust be installed and enabled OK
php_extension openssl should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension tokenizer should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension xmlrpc should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension soap should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension ctype must be installed and enabledmust be installed and enabled OK
php_extension zip must be installed and enabledmust be installed and enabled OK
php_extension gd should be installed and enabled for best resultsshould be installed and enabled for best results OK
php_extension simplexml must be installed and enabledmust be installed and enabled OK
php_extension spl must be installed and enabledmust be installed and enabled OK
php_extension pcre must be installed and enabledmust be installed and enabled OK
php_extension dom must be installed and enabledmust be installed and enabled OK
php_extension xml must be installed and enabledmust be installed and enabled OK
php_extension json must be installed and enabledmust be installed and enabled OK
php_extension hash must be installed and enabledmust be installed and enabled OK
php_setting memory_limit recommended setting detectedrecommended setting detected OK
php_setting safe_mode recommended setting detectedrecommended setting detected OK
php_setting file_uploads recommended setting detectedrecommended setting detected OK
You must solve all the environmental problems (errors) found above before proceeding to install this Moodle version!
 
As to the first one regarding UTF-8.  I'm not sure if this makes any difference but I have 30+ character options to select from whenever I want or need to edit a file via the file manager.  I usually select UTF-8 but it doesn't allow me to set it as a default.  
 
As for the error I get regarding the php.ini file.  Here is what mine currently looks like:

register_globals = off
upload_max_filesize = 60M
post_max_size = 60M

Now, if I add in the intll.dll lines as mentioned during the install/in the instructions, I still get the same 2 errors.  

So what am I doing wrong?  Assistance is sincerely appreciated!

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Installation Issues 2.4.1+
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

I hit this problem the other day on my development server. I think they recently made the checks that the installer does stricter.

In the 

$CFG->dboptions = array(
//
...
);

bit if your config.php file, make sure you have set

    'dbcollation' => 'utf8_bin',

 as one of the options.

 
Average of ratings: -
Picture of Rick Jerz
Re: Installation Issues 2.4.1+
Group Particularly helpful Moodlers

I am wondering if the only serious problem might be that you forgot to set "collation" to utf8_unicode_ci in your database.  I do this using phpMyAdmin in cPanel.  This should remove the "red" check.  The "yellow" warning might not bother the install.

 
Average of ratings: -
Picture of Mydnyte Syn
Re: Installation Issues 2.4.1+
 

Okay, I added 'dbcollation' => 'utf8_bin', to the config file.  

 

I went to my phpMyAdmin and clicked on the database name for my Moodle but the database isn't even created yet.  I can't get to that point in the installation process because of that red error.  I still have that error.  

 
Average of ratings: -
Picture of Ken Task
Re: Installation Issues 2.4.1+
 
Average of ratings: -
Picture of Mydnyte Syn
Re: Installation Issues 2.4.1+
 

THANK YOU!  That solved the issue smile

 
Average of ratings: -
Picture of Ken Task
Re: Installation Issues 2.4.1+
Group Particularly helpful Moodlers

In addition to and for your future reference, linux (thanks for including the server setup) doesn't use .dll extensions to php.  .dll's are Winders.  So when reading instructions, one has to sometimes translate platform information provided.  Just one more bit of info next time: hosting provider.  Who?  All are NOT equal. :|

Apparently, you are remotely hosted.  Some settings for PHP cannot be set via .htacess.  PHP_INI_PERDIR (per directory), PHP_INI_SYSTEM (the system php.ini not the customer php.ini), and PHP_INI_ALL (all).

Reference: http://php.net/manual/en/ini.list.php

If the php-intl extension does not show in a phpinfo out put, more than likely one cannot add an extension on shared hosting.  Check with hosting provider.

'spirit of sharing', Ken

 

 
Average of ratings: -
Picture of Mydnyte Syn
Re: Installation Issues 2.4.1+
 

My hosting provider is TotalChoice hosting.  I have access to and can edit my .htaccess and php.ini files but where do I go to see if the php-intl extension is in the phpinfo output?  

 

Thanks for the assistance everyone smile  I appreciate it. 

 
Average of ratings: -
Picture of Ken Task
Re: Installation Issues 2.4.1+
Group Particularly helpful Moodlers

One has to create a phpinfo.php page and place it document root if Moodle is not installed (Moodle once installed, BTW, does have a phpinfo tool).

Please see: http://php.net/manual/en/function.phpinfo.php

'spirit of sharing', Ken

 
Average of ratings: -