Resource types

URL/Repositories Issue

This discussion has been locked because a year has elapsed since the last post. Please start a new discussion topic.
Picture of Helen Foster
Re: URL/Repositories Issue
Group Core developersGroup Documentation writersGroup Moodle HQGroup Particularly helpful MoodlersGroup Plugin developersGroup TestersGroup Translators

Hi Ralf,

Which repositories do you have enabled on your site? I just tried adding a URL resource to a course on and had Flickr, YouTube, Wikimedia, Dropbox and Picasa listed as repositories in the file picker.

One thing to note is that the repositories listed in the file picker depend which ones have been enabled by the administrator and also on the context in which you access the file picker (from the documentation File picker).

Average of ratings: -
Picture of Ralph Blakeslee
Re: URL/Repositories Issue

Hello Helen!

I have the following repositories listed as "Enabled and visible" under the Manage repositories page:

  • Server files
  • Recent files
  • Upload a file
  • Private files
  • File system

The File system repository has the following settings:

  • 2 site-wide common instances
  • 2 course-wide common instances
  • 0 user private instances

I should have mentioned that I am using v 2.4.1 in my earlier post. 

I will review the File picker documentation more closely.  As I stated, it is the one aspect of the new Moodle (I have been a convert since v 1.5) that I can not seem to get my head around.

Many thanks


Average of ratings: -
Mary Cooch
Re: URL/Repositories Issue
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

Hi Ralph. If you are using the URL option then I think you need to have website-repositories like Flickr or Wikimedia enabled, as Helen suggests, because they are places you can "choose a link" from. If you want to display files from the repositories you mention in your post then you would select the "file" option.

Average of ratings: Useful (1)
Picture of Ralph Blakeslee
Re: URL/Repositories Issue

Hi Mary,

Thanks.  I was able enable Wikimedia and that worked, so now I have a better understanding of that function. 

I think you are right, what I am really trying to do is use the File Resource, and I need to get my head around the whole Repository system.

What I am trying to do is upload zipped files which contain an e-book.  I also need to address the restrictions on upload file size restrictions.

Thanks for the direction.  I will keep pushing forward.


Average of ratings: -
Picture of Ralph Blakeslee
Re: URL/Repositories Issue

Mary & Helen,

First, thanks for the help.  I tried using the file resouce rather then the url.  I uploaded my files (a group of files I use for the my e-book that is displayed using flash).  I succesfully use the file rescourse to find the index.hmtl file in the folider.  When I click on the file link in the classroom this is what I get:

I do have the flash player installed in the web browser (chrome).  Not sure what to make of this.



Average of ratings: -