SCORM

 
 
Picture of Kyle Scallan
Scorm Not Displaying
 

I installed Moodle 2.4 on 2 of my webites recently and uploaded scorm packages (version 1.2) using Adobe Presenter as an authoring tool.  Everything worked perfectly for days.  Then today, the scorm packages do not open.  It continues to churn as if it is going to open but it never does.  To test this, I installed Moodle 2.4.1 into another directory this morning.  I added a scorm package and the same issue occurred.  I'm using Siteground for hosting.  Please let me know if this is a known issue, a setting, or if you need additional information from me.

Thanks

 
Average of ratings: -
Picture of Amy Groshek
Re: Scorm Not Displaying
Group DevelopersGroup Particularly helpful MoodlersGroup Testers
In my experience, without having seen your content or looked at your environment, this kind of issue is commonly associated with zlib compression. You can check your site's phpinfo page to see if zlib compression is enabled.

I have also seen this on sites where Moodle filters were being applied to uploaded files.
 
Average of ratings: -
Picture of Kyle Scallan
Re: Scorm Not Displaying
 

Yes zlib compression is enabled.  

Also, I just installed Moodle 2.01 and it appears to be working.  Not sure why the newer version won't work.

Thanks

 
Average of ratings: -
Picture of Amy Groshek
Re: Scorm Not Displaying
Group DevelopersGroup Particularly helpful MoodlersGroup Testers
So... disable zlib compression and see if that helps. Also make sure your filters are not filtering uploaded files.
 
Average of ratings: -
Picture of Kyle Scallan
Re: Scorm Not Displaying
 

Please see attached error messages.


 
Average of ratings: -
Picture of Amy Groshek
Re: Scorm Not Displaying
Group DevelopersGroup Particularly helpful MoodlersGroup Testers
That's not an error that's caused by the LMS. Your SCO calls LMSFinish(), closing the API, and then attempts to save more data to the LMS.
 
Average of ratings: -
Picture of Kyle Scallan
Re: Scorm Not Displaying
 

I don't understand the error or how to correct it.  This particular scorm worked fine in Moodle...then stopped working.  It also works fine in JoomlaLMS, Docebo, and efront.

 
Average of ratings: -
Picture of Amy Groshek
Re: Scorm Not Displaying
Group DevelopersGroup Particularly helpful MoodlersGroup Testers
To correct that error you probably need to change your SCORM activity to not continue to try and set values after it's closed the API.
 
Average of ratings: -