Installation help

 
 
Picture of Shane Mathew
2.4 No Icons or Themes
 

I just installed 2.4 following the Moodle documentation. The Moodle pages themselves load, but there are no images or themes. Admin links don't work...all the links become "edit.php?id=2&course=1". The login page says "Cookies must be enabled in your browser" even though cookies are enabled in all the browsers I've checked. $CFG->wwwroot is set to the correct address, which is the same address I'm using in my browsers to access through the Internet.

Moodle 2.4, nginx 1.3.8, PHP 5.4.6-1, MariaDB 5.5.28a

 

 
Average of ratings: -
Picture of Howard Miller
Re: 2.4 No Icons or Themes
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

nginx is suddenly popular this week!

Firstly, try Site administration > Server > Http.  Find the option 'Slasharguments' and untick it. Does that help?

 
Average of ratings: -
Picture of Shane Mathew
Re: 2.4 No Icons or Themes
 

I clicked the "Server > Http" link and the page didn't change. The URI changed as I indicated in my original post. I added "$CFG->slasharguments=1" to config.php, but that apparently didn't help.

 
Average of ratings: -
Picture of Howard Miller
Re: 2.4 No Icons or Themes
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Is your site public? Can we get a look?

 
Average of ratings: -
Picture of Shane Mathew
Re: 2.4 No Icons or Themes
 

Sure...it's just a test server. http://revshanemathew.com/moodle

 
Average of ratings: -
José de Jesús
Re: 2.4 No Icons or Themes
Group Particularly helpful Moodlers
Peace.

Hi. Shene Mathew:

It is likely that when editing the theme (yui_combo) you're using something has been erased.
Try to restore the standard Moodle theme for you to check out what's missing.

Tell us how it went.

Greetings.

José de Jesús.





 
Average of ratings: -
Picture of Howard Miller
Re: 2.4 No Icons or Themes
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

As far as I can see, slasharguments is NOT turned off. Manipulating the links manually to look like it is off generates correct (looking) CSS.

 

You want $CFG->slasharguments=0 in your config.php btw.

Depending on your circumstances you may have to fight with your local web caches to actually see the change after you do that.

 
Average of ratings: -
Picture of Shane Mathew
Re: 2.4 No Icons or Themes
 

Thanks! It was the slasharguments issue. I forgot that 1 != 0.

 
Average of ratings: -