Hotpot (plugin)

Flash musicplayer button not working in Moodle 2.4 in TaskChain

 
 
Picture of Glenys Hanson
Flash musicplayer button not working in Moodle 2.4 in TaskChain
Group Particularly helpful Moodlers

Hi again Gordon,

I downloaded the musicplayer Flash button from Stan Bogdanov's site on his Flash mp3 players page. I made an exercise which validates and works fine outside of Moodle. It also works fine on Moodle 1.9.19 in QuizPort as you can see here: 1-9 Audio. It also works in Book on 1.9.19.

But on Moodle 2.4 it doesn't as you can see here in TaskChain: 1-9 Audio - it doesn't work in Book either.

Any ideas?

Cheers,

Glenys

 
Average of ratings: -
Stan Bogdanov
Re: Flash musicplayer button not working in Moodle 2.4 in TaskChain
 

Hi Glenys,

I looked at the source code (see below) and the path to the swf is discovered (in blue), but the path to the mp3 file is not (in green). I guess song_url (in red) is not among the parameters for url rewriting. It should be easy for Gordon to include it:

<object type="application/x-shockwave-flash" data="http://bateson.kanazawa-gu.ac.jp/24/pluginfile.php/116/mod_taskchain/sourcefile/1-9/musicplayer_button.swf?&amp;song_url=06.mp3&amp;b_bgcolor=E6E6FA&amp;b_fgcolor=E6E6FA&amp;b_colors=000000,000000,aa0000&amp;" width="17" height="17" style="vertical-align:middle;"><param name="wmode" value="transparent"></object>

Cheers

Stan

 
Average of ratings: -
Picture of Glenys Hanson
Re: Flash musicplayer button not working in Moodle 2.4 in TaskChain
Group Particularly helpful Moodlers

Hi Stan,

Thanks for that. I do hope it's something easy for Gordon to fix.

I have a lot of exercises where a button player is appropriate.

Cheers,

Glenys

 
Average of ratings: -
Picture of Gordon Bateson
Re: Flash musicplayer button not working in Moodle 2.4 in TaskChain
Group DevelopersGroup Particularly helpful MoodlersGroup Translators

Glenys,
the URL you gave for the exercise running in Moodle 1.9, is a link to the HTML file within the course files area. Relative links work fine in that situation, so the "song_url" works just as it is.

I suspect that if you ran that html file via QuizPort the player would not appear because the "song_url" needs to be converted to am absolute URL in that situation.

Thanks for supplying the file for me to test on. I will try to have a look at it in the near future.

Gordon

 
Average of ratings: -
Picture of Glenys Hanson
Re: Flash musicplayer button not working in Moodle 2.4 in TaskChain
Group Particularly helpful Moodlers

Hi Gordon,

You're perfectly right, of course, it doesn't work in QuizPort either. I was just in a muddle.

I don't understand why some Flash players work and not others but there's no rush - just testing and learning about TaskChain and Moodle 2.4.

Cheers,

Glenys

 

 
Average of ratings: -
Picture of Gordon Bateson
Re: Flash musicplayer button not working in Moodle 2.4 in TaskChain
Group DevelopersGroup Particularly helpful MoodlersGroup Translators

Dear Glenys and Stan,

I have made the HotPot module for Moodle 2.x aware of the "song_url" setting and checked (using Glenys's file and Stan's sample code) that the "song_url" is now correctly converted to a absolute URL.

I have also modified the QuizPort and TaskChain modules so they can detect the "song_url" setting too.

best regards
Gordon

 
Average of ratings:Useful (1)
Stan Bogdanov
Re: Flash musicplayer button not working in Moodle 2.4 in TaskChain
 

Thanks Gordon!

I'll check it on my Moodle and report as soon as I have a moment.

cheers
Stan

 
Average of ratings:Useful (1)