Authentication

 
 
Picture of Andrew Lorbach
Re: NTLM SSO Problems
 

Drop this code into a php file in your moodle directory:

 

<?php
if (isset($_SERVER['REMOTE_USER']) && !empty($_SERVER['REMOTE_USER'])) {
    echo "<p>NTLM authentication seems to be working. User: " . $_SERVER['REMOTE_USER'] . "</p>";
} else {
    echo '<p>NTLM is not working</p>';
}
?>

 

Give it a name like NTLM_test.php and then run it in your browser http://moodle.site/ntlm_test.php and see what it gives you.

Also head into IIS. Browse through the moodle directory and find the ntlm_magic.php file (I think that's what it's called, not at work so I can't check 100%). You may have to switch to content view in iis. When you have the file selected on the right it will have providers. Select the option to change providors and there should be negotiate and ntlm in the list. Move ntlm up to the top of the list. Restart your moodle site and try again.

 
Average of ratings: -
Picture of Mitch Douglas
Re: NTLM SSO Problems
 

To add to this, although I didn't try this, it turned out that the settings for our version of IE in the internal college network didn't put Moodle in it's allowed websites. Our network manager has changed this and it is now working.

 
Average of ratings: -